Skip to content
Laskyr

Plugins · envo-extra · data as of 2026-11-04

Is Envo Extra safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.9.24)

As of 2026-11-04. 7 issues are on record for older versions; version 1.9.14 or newer fixes all of them that state a fix.

Latest version
1.9.24
Last updated
2026-10-08
Active installs
20,000+
Known issues on record
7
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Extra addon for EnvoThemes Themes — by EnvoThemes

What to do

  1. Update to the latest version (1.9.24). Anything older than 1.9.14 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get envo-extra --field=version shows what you run; wp plugin update envo-extra updates it.

Check your version

Known vulnerabilities

7 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-32386 · published 2026-03-13

Missing authorization check in Envo Extra (1.9.13 and older)

Affected
1.9.13 and older
Fixed in
1.9.14
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in EnvoThemes Envo Extra envo-extra allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Envo Extra: from n/a through <= 1.9.13.

NVD CVE-2026-32386Patchstack advisory

medium 6.5 CVE-2025-66066 · published 2025-11-21

Stored cross-site scripting (XSS) in Envo Extra (1.9.11 and older)

Affected
1.9.11 and older
Fixed in
1.9.12
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in EnvoThemes Envo Extra envo-extra allows Stored XSS.This issue affects Envo Extra: from n/a through <= 1.9.11.

NVD CVE-2025-66066Patchstack advisory

medium 4.3 CVE-2025-47471 · published 2025-05-07

Missing authorization check in Envo Extra (1.9.9 and older)

Affected
1.9.9 and older
Fixed in
1.9.10
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in EnvoThemes Envo Extra envo-extra allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Envo Extra: from n/a through <= 1.9.9.

NVD CVE-2025-47471Patchstack advisory

medium 4.3 CVE-2024-10770 · published 2024-11-09

Information disclosure in Envo Extra (1.9.3 and older)

Affected
1.9.3 and older
Fixed in
1.9.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Envo Extra plugin for WordPress is vulnerable to Information Exposure in all versions up to, and including, 1.9.3 via the 'elementor-template' shortcode due to insufficient restrictions on which posts can be included. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract data from private or draft posts created by Elementor that they should not have access to.

NVD CVE-2024-10770Wordfence advisoryCode change (fix)

medium 5.4 CVE-2024-5645 · published 2024-06-07

Stored cross-site scripting (XSS) in Envo Extra (1.8.23 and older)

Affected
1.8.23 and older
Fixed in
1.8.24 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Envo Extra plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘button_css_id’ parameter within the Button widget in all versions up to, and including, 1.8.23 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-5645Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 5.4 CVE-2024-4385 · published 2024-05-16

Stored cross-site scripting (XSS) in Envo Extra (1.8.16 and older)

Affected
1.8.16 and older
Fixed in
1.8.17 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Envo Extra plugin for WordPress is vulnerable to Stored Cross-Site Scripting via multiple parameters in versions up to, and including, 1.8.16 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level permissions and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-4385Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2024-32456 · published 2024-04-17

Stored cross-site scripting (XSS) in Envo Extra (1.8.11 and older)

Affected
1.8.11 and older
Fixed in
1.8.12
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in EnvoThemes Envo Extra allows Stored XSS.This issue affects Envo Extra: from n/a through 1.8.11.

NVD CVE-2024-32456Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Envo Extra vulnerability status badge
<a href="https://laskyr.com/plugins/envo-extra"><img src="https://laskyr.com/plugins/envo-extra/badge.svg" alt="Envo Extra vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit