Plugins · envialosimple-email-marketing-y-newsletters-gratis · data as of 2026-11-04
Is EnvíaloSimple safe? Known vulnerabilities and latest version
- Latest version
- 2.4.7
- Last updated
- 2026-10-01
- Active installs
- 1,000+
- Known issues on record
- 6
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.0+
El plugin de EnvíaloSimple te permitirá crear y enviar Newsletters de calidad profesional, en minutos y directamente desde tu Wordpress. — by DonWeb
What to do
- Update to the latest version (2.4.7). Anything older than 2.4.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get envialosimple-email-marketing-y-newsletters-gratis --field=version shows what you run; wp plugin update envialosimple-email-marketing-y-newsletters-gratis updates it.
Check your version
Known vulnerabilities
6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.9 CVE-2026-7618 · published 2026-05-27
SQL injection in EnvíaloSimple (2.4.5 and older)
- Affected
- 2.4.5 and older
- Fixed in
- 2.4.6 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The EnvíaloSimple: Email Marketing y Newsletters plugin for WordPress is vulnerable to time-based blind SQL Injection via the 'orderby' parameter in all versions up to, and including, 2.4.5 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
medium 5.8 CVE-2024-32587 · published 2024-04-18
Reflected cross-site scripting (XSS) in EnvíaloSimple (2.2 and older)
- Affected
- 2.2 and older
- Fixed in
- 2.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in EnvialoSimple EnvíaloSimple allows Reflected XSS.This issue affects EnvíaloSimple: from n/a through 2.2.
high 8.8 CVE-2024-2125 · published 2024-04-09
Cross-site request forgery (CSRF) in EnvíaloSimple (2.3 and older)
- Affected
- 2.3 and older
- Fixed in
- 2.4.2 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The EnvíaloSimple: Email Marketing y Newsletters plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 2.3. This is due to missing or incorrect nonce validation on the gallery_add function. This makes it possible for unauthenticated attackers to upload malicious files via a forged request granted they can trick a site administrator into performing an action such as clicking on a link. The Cross-Site Request Forgery was patched in 2.4, however, nothing was done about the ability to upload arbitrary files.
NVD CVE-2024-2125Wordfence advisoryCode change (fix)Plugin source
medium 6.5 CVE-2023-51416 · published 2024-03-26
Cross-site request forgery (CSRF) in EnvíaloSimple (2.2 and older)
- Affected
- 2.2 and older
- Fixed in
- 2.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in EnvialoSimple EnvíaloSimple.This issue affects EnvíaloSimple: from n/a through 2.2.
critical 9.8 CVE-2023-51414 · published 2023-12-29
PHP object injection in EnvíaloSimple (2.1 and older)
- Affected
- 2.1 and older
- Fixed in
- 2.2 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Deserialization of Untrusted Data vulnerability in EnvialoSimple EnvíaloSimple: Email Marketing y Newsletters.This issue affects EnvíaloSimple: Email Marketing y Newsletters: from n/a through 2.1.
medium 4.3 CVE-2014-4527 · published 2014-07-02
Cross-site scripting (XSS) in EnvíaloSimple (older than 1.98)
- Affected
- older than 1.98
- Fixed in
- 1.98
- Range from
- advisory text · score by NVD
Details from the advisory
Multiple cross-site scripting (XSS) vulnerabilities in paginas/vista-previa-form.php in the EnvialoSimple: Email Marketing and Newsletters (envialosimple-email-marketing-y-newsletters-gratis) plugin before 1.98 for WordPress allow remote attackers to inject arbitrary web script or HTML via the (1) FormID or (2) AdministratorID parameter.
Recent activity
- 2026-10-01 — latest release on wordpress.org (2.4.7).
- 2026-05-27 — SQL injection disclosed (CVE-2026-7618), fixed in 2.4.6.
- 2024-04-18 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-32587), fixed in 2.3.
- 2024-04-09 — Cross-site request forgery (CSRF) disclosed (CVE-2024-2125), fixed in 2.4.2.
Get an email when EnvíaloSimple has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for EnvíaloSimple (envialosimple-email-marketing-y-newsletters-gratis) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (2) · Cross-site request forgery (CSRF) (2) · SQL injection (1) · PHP object injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/envialosimple-email-marketing-y-newsletters-gratis (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/envialosimple-email-marketing-y-newsletters-gratis"><img src="https://laskyr.com/plugins/envialosimple-email-marketing-y-newsletters-gratis/badge.svg" alt="EnvíaloSimple vulnerability status"></a>