Plugins · enquiry-quotation-for-woocommerce · data as of 2026-11-04
Is PiWeb Product Enquiry or product catalog for W… safe? Known vulnerabilities and latest version
- Latest version
- 2.2.34.63
- Last updated
- 2026-10-25
- Active installs
- 1,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4
Product enquiry for WooCommerce and product catalog plugin that can save enquiries and email the WooCommerce product enquiry as well — by PI Web Solution
What to do
- Update to the latest version (2.2.34.63). Anything older than 2.2.34.44 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get enquiry-quotation-for-woocommerce --field=version shows what you run; wp plugin update enquiry-quotation-for-woocommerce updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 CVE-2026-59512 · published 2026-07-23
Cross-site scripting (XSS) in PiWeb Product Enquiry or product catalog for W… (2.2.34.43 and older)
- Affected
- 2.2.34.43 and older
- Fixed in
- 2.2.34.44
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Cross Site Scripting (XSS) in Product Enquiry for WooCommerce <= 2.2.34.43 versions.
high 8.8 CVE-2024-8922 · published 2024-09-27
PHP object injection in PiWeb Product Enquiry or product catalog for W… (2.2.33.33 and older)
- Affected
- 2.2.33.33 and older
- Fixed in
- 2.2.33.34 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Product Enquiry for WooCommerce, WooCommerce product catalog plugin for WordPress is vulnerable to PHP Object Injection in all versions up to, and including, 2.2.33.32 via deserialization of untrusted input in enquiry_detail.php. This makes it possible for authenticated attackers, with Author-level access and above, to inject a PHP Object. No known POP chain is present in the vulnerable software. If a POP chain is present via an additional plugin or theme installed on the target system, it could allow the attacker to delete arbitrary files, retrieve sensitive data, or execute code.
medium 4.8 CVE-2023-29170 · published 2023-04-07
Stored cross-site scripting (XSS) in PiWeb Product Enquiry or product catalog for W… (2.2.12 and older)
- Affected
- 2.2.12 and older
- Fixed in
- 2.2.13
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. (admin+) Stored Cross-site Scripting (XSS) vulnerability in PI Websolution Product Enquiry for WooCommerce, WooCommerce product catalog plugin <= 2.2.12 versions.
Recent activity
- 2026-10-25 — latest release on wordpress.org (2.2.34.63).
- 2026-07-23 — Cross-site scripting (XSS) disclosed (CVE-2026-59512), fixed in 2.2.34.44.
- 2024-09-27 — PHP object injection disclosed (CVE-2024-8922), fixed in 2.2.33.34.
- 2023-04-07 — Stored cross-site scripting (XSS) disclosed (CVE-2023-29170), fixed in 2.2.13.
Get an email when PiWeb Product Enquiry or product catalog for W… has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for PiWeb Product Enquiry or product catalog for W… (enquiry-quotation-for-woocommerce) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by PI Web Solution (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · PHP object injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/enquiry-quotation-for-woocommerce (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/enquiry-quotation-for-woocommerce"><img src="https://laskyr.com/plugins/enquiry-quotation-for-woocommerce/badge.svg" alt="PiWeb Product Enquiry or product catalog for W… vulnerability status"></a>