Skip to content
Laskyr

Plugins · endless-posts-navigation · data as of 2026-11-04

Is Endless Posts Navigation safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.4.0)

As of 2026-11-04. 2 issues are on record for older versions; version 2.3.0 or newer fixes all of them that state a fix.

Latest version
2.4.0
Last updated
2026-10-26
Active installs
100+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.0+

Endless Posts Navigation is a great plugin to loop your posts/pages with alphabetic order. It is simple to use. — by Fahad Mahmood

What to do

  1. Update to the latest version (2.4.0). Anything older than 2.3.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get endless-posts-navigation --field=version shows what you run; wp plugin update endless-posts-navigation updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.3 CVE-2026-25332 · published 2026-02-19

Missing authorization check in Endless Posts Navigation (2.2.9 and older)

Affected
2.2.9 and older
Fixed in
2.3.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Fahad Mahmood Endless Posts Navigation endless-posts-navigation allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Endless Posts Navigation: from n/a through <= 2.2.9.

NVD CVE-2026-25332Patchstack advisory

medium 6.1 CVE-2024-49629 · published 2024-10-20

Cross-site request forgery (CSRF) in Endless Posts Navigation (2.2.7 and older)

Affected
2.2.7 and older
Fixed in
2.2.8
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Fahad Mahmood Endless Posts Navigation endless-posts-navigation allows Stored XSS.This issue affects Endless Posts Navigation: from n/a through <= 2.2.7.

NVD CVE-2024-49629Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Endless Posts Navigation vulnerability status badge
<a href="https://laskyr.com/plugins/endless-posts-navigation"><img src="https://laskyr.com/plugins/endless-posts-navigation/badge.svg" alt="Endless Posts Navigation vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit