Plugins · employee-spotlight · data as of 2026-11-04
Is Employee Spotlight safe? Known vulnerabilities and latest version
- Latest version
- 5.1.5
- Last updated
- 2026-02-25
- Active installs
- 300+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11
Showcase your team with beautiful, responsive layouts: grid, carousel, cards, and more. Perfect for meet-the-team pages and employee highlights. — by emarket-design
What to do
- Update to the latest version (5.1.5). Anything older than 5.1.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get employee-spotlight --field=version shows what you run; wp plugin update employee-spotlight updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.3 CVE-2025-13403 · published 2025-12-13
Missing authorization check in Employee Spotlight (5.1.3 and older)
- Affected
- 5.1.3 and older
- Fixed in
- 5.1.4 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Employee Spotlight – Team Member Showcase & Meet the Team Plugin for WordPress is vulnerable to unauthorized tracking settings modification due to missing authorization validation on the employee_spotlight_check_optin() function in all versions up to, and including, 5.1.3. This makes it possible for authenticated attackers, with Subscriber-level access and above, to enable or disable tracking settings.
NVD CVE-2025-13403Wordfence advisoryCode change (fix)Plugin source
medium 6.4 CVE-2025-12090 · published 2025-11-01
Stored cross-site scripting (XSS) in Employee Spotlight (5.1.2 and older)
- Affected
- 5.1.2 and older
- Fixed in
- 5.1.3 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Employee Spotlight – Team Member Showcase & Meet the Team Plugin plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Social URLs in all versions up to, and including, 5.1.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
high 8.1 CVE-2025-53583 · published 2025-08-28
PHP object injection in Employee Spotlight (5.1.1 and older)
- Affected
- 5.1.1 and older
- Fixed in
- 5.1.2
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Deserialization of Untrusted Data vulnerability in emarket-design Employee Spotlight employee-spotlight allows Object Injection.This issue affects Employee Spotlight: from n/a through <= 5.1.1.
Recent activity
- 2026-02-25 — latest release on wordpress.org (5.1.5).
- 2025-12-13 — Missing authorization check disclosed (CVE-2025-13403), fixed in 5.1.4.
- 2025-11-01 — Stored cross-site scripting (XSS) disclosed (CVE-2025-12090), fixed in 5.1.3.
- 2025-08-28 — PHP object injection disclosed (CVE-2025-53583), fixed in 5.1.2.
Get an email when Employee Spotlight has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Employee Spotlight (employee-spotlight) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by emarket-design (3 tracked)
Types found in this plugin: Missing authorization (1) · Cross-site scripting (XSS) (1) · PHP object injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/employee-spotlight (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/employee-spotlight"><img src="https://laskyr.com/plugins/employee-spotlight/badge.svg" alt="Employee Spotlight vulnerability status"></a>