Skip to content
Laskyr

Plugins · emplibot · data as of 2026-11-04

Is Emplibot safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.0)

As of 2026-11-04. 1 issue is on record for older versions; version 1.1.0 or newer fixes all of them that state a fix.

Latest version
1.1.0
Last updated
2025-11-19
Active installs
100+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
6.8.12 · PHP 7.2+

Automated keyword research, automated blogging, with internal and external links, engaging infographics, unique featured images, and more. — by Emplibot

What to do

  1. Update to the latest version (1.1.0). Anything older than 1.1.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get emplibot --field=version shows what you run; wp plugin update emplibot updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.4 CVE-2025-11970 · published 2025-12-13

Server-side request forgery (SSRF) in Emplibot (1.0.9 and older)

Affected
1.0.9 and older
Fixed in
1.1.0 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Emplibot – AI Content Writer with Keyword Research, Infographics, and Linking | SEO Optimized | Fully Automated plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 1.0.9 via the emplibot_call_webhook_with_error() and emplibot_process_zip_data() functions. This makes it possible for authenticated attackers, with Administrator-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.

NVD CVE-2025-11970Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Emplibot vulnerability status badge
<a href="https://laskyr.com/plugins/emplibot"><img src="https://laskyr.com/plugins/emplibot/badge.svg" alt="Emplibot vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit