Skip to content
Laskyr

Plugins · empik-for-woocommerce · data as of 2026-11-04

Is Empik for Woocommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.5.5)

As of 2026-11-04. 2 issues are on record for older versions; version 1.5.2 or newer fixes all of them that state a fix.

Latest version
1.5.5
Last updated
2026-09-28
Active installs
500+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Wtyczka do WooCommerce umożliwiająca integrację z Empik. Wysyłaj produkty i oferty, pobieraj i obsługuj zamówienia z poziomu WooCommerce. — by empik

What to do

  1. Update to the latest version (1.5.5). Anything older than 1.5.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get empik-for-woocommerce --field=version shows what you run; wp plugin update empik-for-woocommerce updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-9766 · published 2026-09-19

Missing authorization check in Empik for Woocommerce (1.5.1 and older)

Affected
1.5.1 and older
Fixed in
1.5.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Empik for Woocommerce plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 1.5.1. This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for authenticated attackers, with subscriber-level access and above, to modify arbitrary WooCommerce product metadata, including Empik logistic class (_empik_logistic_klass), product state (_empik_product_state, _empik_product_state_all_variants), and Empik export and offer flags on any product in the store.

NVD CVE-2026-9766Wordfence advisoryCode change (fix)Plugin source

critical 9.8 CVE-2025-32568 · published 2025-04-11

PHP object injection in Empik for Woocommerce (1.4.3 and older)

Affected
1.4.3 and older
Fixed in
1.4.4
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in empik EmpikPlace for Woocommerce empik-for-woocommerce allows Object Injection.This issue affects EmpikPlace for Woocommerce: from n/a through <= 1.4.3.

NVD CVE-2025-32568Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Empik for Woocommerce vulnerability status badge
<a href="https://laskyr.com/plugins/empik-for-woocommerce"><img src="https://laskyr.com/plugins/empik-for-woocommerce/badge.svg" alt="Empik for Woocommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit