Skip to content
Laskyr

Plugins · emergency-password-reset · data as of 2026-11-04

Is Emergency password reset safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (9.4)

As of 2026-11-04. 2 issues are on record for older versions; version 9.4 or newer fixes all of them that state a fix.

Latest version
9.4
Last updated
2025-11-24
Active installs
800+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.8.12

This plugin allows the admin to reset all the passwords and automatically email out the link to reset — by andy_moyle

What to do

  1. Update to the latest version (9.4). Anything older than 9.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get emergency-password-reset --field=version shows what you run; wp plugin update emergency-password-reset updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2024-35648 · published 2026-06-17

Cross-site request forgery (CSRF) in Emergency password reset (8.0 and older)

Affected
8.0 and older
Fixed in
9.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site request forgery (CSRF) vulnerability in Andy Moyle Emergency Password Reset allows Cross Site Request Forgery. This issue affects Emergency Password Reset: from n/a through 8.0.

NVD CVE-2024-35648Patchstack advisory

medium 4.3 CVE-2025-57942 · published 2025-09-22

Cross-site request forgery (CSRF) in Emergency password reset (9.3 and older)

Affected
9.3 and older
Fixed in
9.4
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in andy_moyle Emergency Password Reset emergency-password-reset allows Cross Site Request Forgery.This issue affects Emergency Password Reset: from n/a through <= 9.3.

NVD CVE-2025-57942Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Emergency password reset vulnerability status badge
<a href="https://laskyr.com/plugins/emergency-password-reset"><img src="https://laskyr.com/plugins/emergency-password-reset/badge.svg" alt="Emergency password reset vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit