Skip to content
Laskyr

Plugins · embed-privacy · data as of 2026-11-04

Is Embed Privacy safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.14.0)

As of 2026-11-04. 3 issues are on record for older versions; version 1.12.4 or newer fixes all of them that state a fix.

Latest version
1.14.0
Last updated
2026-08-12
Active installs
10,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

Embed Privacy prevents the loading of embedded external content and allows your site visitors to opt-in. — by epiphyt

What to do

  1. Update to the latest version (1.14.0). Anything older than 1.12.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get embed-privacy --field=version shows what you run; wp plugin update embed-privacy updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-57346 · published 2026-06-29

Path traversal / file read in Embed Privacy (1.12.3 and older)

Affected
1.12.3 and older
Fixed in
1.12.4
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Limitation of a Pathname to a Restricted Directory ('Path Traversal') vulnerability in Epiphyt Embed Privacy allows Path Traversal. This issue affects Embed Privacy: from n/a through 1.12.3.

NVD CVE-2026-57346Patchstack advisory

medium 5.4 CVE-2023-51694 · published 2024-02-01

Stored cross-site scripting (XSS) in Embed Privacy (1.8.0 and older)

Affected
1.8.0 and older
Fixed in
1.8.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Epiphyt Embed Privacy allows Stored XSS.This issue affects Embed Privacy: from n/a through 1.8.0.

NVD CVE-2023-51694Patchstack advisory

medium 5.4 CVE-2023-48300 · published 2023-11-20

Stored cross-site scripting (XSS) in Embed Privacy (older than 1.8.1)

Affected
older than 1.8.1
Fixed in
1.8.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The `Embed Privacy` plugin for WordPress that prevents the loading of embedded external content is vulnerable to Stored Cross-Site Scripting via `embed_privacy_opt_out` shortcode in versions up to, and including, 1.8.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Version 1.8.1 contains a patch for this issue.

NVD CVE-2023-48300d.prgithub.comgithub.comgithub.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Embed Privacy vulnerability status badge
<a href="https://laskyr.com/plugins/embed-privacy"><img src="https://laskyr.com/plugins/embed-privacy/badge.svg" alt="Embed Privacy vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit