Skip to content
Laskyr

Plugins · embed-pdf-viewer · data as of 2026-11-04

Is Embed PDF Viewer safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.5.1)

As of 2026-11-04. 3 issues are on record for older versions; version 2.4.8 or newer fixes all of them that state a fix.

Latest version
2.5.1
Last updated
2026-08-12
Active installs
20,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Embed a PDF from the Media Library or elsewhere via oEmbed or as a block into an iframe tag. — by Andy Fragen

What to do

  1. Update to the latest version (2.5.1). Anything older than 2.4.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get embed-pdf-viewer --field=version shows what you run; wp plugin update embed-pdf-viewer updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.9 CVE-2026-32349 · published 2026-03-13

Server-side request forgery (SSRF) in Embed PDF Viewer (2.4.7 and older)

Affected
2.4.7 and older
Fixed in
2.4.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Server-Side Request Forgery (SSRF) vulnerability in Andy Fragen Embed PDF Viewer embed-pdf-viewer allows Server Side Request Forgery.This issue affects Embed PDF Viewer: from n/a through <= 2.4.7.

NVD CVE-2026-32349Patchstack advisory

medium 5.9 CVE-2024-56256 · published 2024-12-31

Cross-site scripting (XSS) in Embed PDF Viewer (2.3.1 and older)

Affected
2.3.1 and older
Fixed in
2.4.0
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Andy Fragen Embed PDF Viewer embed-pdf-viewer.This issue affects Embed PDF Viewer: from n/a through <= 2.3.1.

NVD CVE-2024-56256Patchstack advisory

medium 6.4 CVE-2024-9451 · published 2024-10-09

Stored cross-site scripting (XSS) in Embed PDF Viewer (2.4.4 and older)

Affected
2.4.4 and older
Fixed in
2.4.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Embed PDF Viewer plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'height' and 'width' parameters in all versions up to, and including, 2.4.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-9451Wordfence advisoryCode change (fix)wordpress.orgPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Embed PDF Viewer vulnerability status badge
<a href="https://laskyr.com/plugins/embed-pdf-viewer"><img src="https://laskyr.com/plugins/embed-pdf-viewer/badge.svg" alt="Embed PDF Viewer vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit