Skip to content
Laskyr

Plugins · embed-calendly-scheduling · data as of 2026-11-04

Is EMC safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (5.9)

As of 2026-11-04. 3 issues are on record for older versions; version 4.5 or newer fixes all of them that state a fix.

Latest version
5.9
Last updated
2026-09-23
Active installs
10,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Embed Calendly scheduling features in WordPress and optimize your booking flow with custom design, availability indicator, and conversion tools. — by Simpma

What to do

  1. Update to the latest version (5.9). Anything older than 4.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get embed-calendly-scheduling --field=version shows what you run; wp plugin update embed-calendly-scheduling updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-0868 · published 2026-04-19

Stored cross-site scripting (XSS) in EMC (4.4 and older)

Affected
4.4 and older
Fixed in
4.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The EMC – Easily Embed Calendly Scheduling Features plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's calendly shortcode in all versions up to, and including, 4.4 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-0868Wordfence advisoryCode change (fix)

medium 6.5 CVE-2026-32411 · published 2026-03-13

Stored cross-site scripting (XSS) in EMC (4.4 and older)

Affected
4.4 and older
Fixed in
4.5
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Simpma Embed Calendly embed-calendly-scheduling allows Stored XSS.This issue affects Embed Calendly: from n/a through <= 4.4.

NVD CVE-2026-32411Patchstack advisory

medium 5.4 CVE-2023-4995 · published 2023-10-13

Stored cross-site scripting (XSS) in EMC (3.6 and older)

Affected
3.6 and older
Fixed in
3.7 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Embed Calendly plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'calendly' shortcode in versions up to, and including, 3.6 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2023-4995Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
EMC vulnerability status badge
<a href="https://laskyr.com/plugins/embed-calendly-scheduling"><img src="https://laskyr.com/plugins/embed-calendly-scheduling/badge.svg" alt="EMC vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit