Plugins · embed-any-document · data as of 2026-11-04
Is Embed Any Document safe? Known vulnerabilities and latest version
- Latest version
- 2.7.14
- Last updated
- 2026-08-07
- Active installs
- 50,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8
Embed PDF, DOC, PPT and XLS documents easily on your WordPress website with the help of Google Docs Viewer or Microsoft Office Online. — by awsm.in
What to do
- Update to the latest version (2.7.14). Anything older than 2.7.11 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get embed-any-document --field=version shows what you run; wp plugin update embed-any-document updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-18558 · published 2026-10-10
Stored cross-site scripting (XSS) in Embed Any Document (2.7.13 and older)
- Affected
- 2.7.13 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Embed Any Document – Embed PDF, Word, PowerPoint and Excel Files plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'embeddoc' shortcode in all versions up to, and including, 2.7.13 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
medium 6.4 CVE-2025-12885 · published 2025-12-18
Stored cross-site scripting (XSS) in Embed Any Document (2.7.10 and older)
- Affected
- 2.7.10 and older
- Fixed in
- 2.7.11 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Embed Any Document – Embed PDF, Word, PowerPoint and Excel Files plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the sanitize_pdf_src function regex bypass in all versions up to, and including, 2.7.10 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
medium 6.5 CVE-2025-60099 · published 2025-09-26
Stored cross-site scripting (XSS) in Embed Any Document (2.7.7 and older)
- Affected
- 2.7.7 and older
- Fixed in
- 2.7.8
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in awsm.in Embed Any Document embed-any-document allows Stored XSS.This issue affects Embed Any Document: from n/a through <= 2.7.7.
medium 6.4 CVE-2025-1043 · published 2025-02-20
Server-side request forgery (SSRF) in Embed Any Document (2.7.5 and older)
- Affected
- 2.7.5 and older
- Fixed in
- 2.7.6 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Embed Any Document – Embed PDF, Word, PowerPoint and Excel Files plugin for WordPress is vulnerable to Server-Side Request Forgery in all versions up to, and including, 2.7.5 via the 'embeddoc' shortcode. This makes it possible for authenticated attackers, with Contributor-level access and above, to make web requests to arbitrary locations originating from the web application and can be used to query and modify information from internal services.
medium 5.4 CVE-2023-23707 · published 2023-03-23
Stored cross-site scripting (XSS) in Embed Any Document (2.7.1 and older)
- Affected
- 2.7.1 and older
- Fixed in
- 2.7.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting'), Unrestricted Upload of File with Dangerous Type vulnerability in Awsm Innovations Embed Any Document – Embed PDF, Word, PowerPoint and Excel Files allows Stored XSS via upload of SVG and HTML files. This issue affects Embed Any Document – Embed PDF, Word, PowerPoint and Excel Files plugin <= 2.7.1 versions.
Recent activity
- 2026-08-07 — latest release on wordpress.org (2.7.14).
- 2026-10-10 — Stored cross-site scripting (XSS) disclosed (CVE-2026-18558), fix version not stated.
- 2025-12-18 — Stored cross-site scripting (XSS) disclosed (CVE-2025-12885), fixed in 2.7.11.
- 2025-09-26 — Stored cross-site scripting (XSS) disclosed (CVE-2025-60099), fixed in 2.7.8.
Get an email when Embed Any Document has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Embed Any Document (embed-any-document) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (4) · Server-side request forgery (SSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/embed-any-document (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/embed-any-document"><img src="https://laskyr.com/plugins/embed-any-document/badge.svg" alt="Embed Any Document vulnerability status"></a>