Skip to content
Laskyr

Plugins · emails-verification-for-woocommerce · data as of 2026-11-04

Is Customer Email Verification for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.3.1)

As of 2026-11-04. 5 issues are on record for older versions; version 3.3.1 or newer fixes all of them that state a fix.

Latest version
3.3.1
Last updated
2026-10-13
Active installs
8,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4

Enhance WooCommerce security with Email Verification. Ensure genuine customer interactions, eliminate spam, and boost email marketing efficiency. — by WPFactory

What to do

  1. Update to the latest version (3.3.1). Anything older than 3.3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get emails-verification-for-woocommerce --field=version shows what you run; wp plugin update emails-verification-for-woocommerce updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 8.1 CVE-2026-104745 · published 2026-10-16

Privilege escalation in Customer Email Verification for WooCommerce (3.3.0 and older)

Affected
3.3.0 and older
Fixed in
3.3.1 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Customer Email Verification for WooCommerce plugin for WordPress is vulnerable to Privilege Escalation via the `alg_wc_ev_verify_email` parameter in versions up to, and including, 3.3.0. The vulnerability exists because `alg_wc_ev_generate_user_code()` generates the per-user activation secret using `wp_rand(100)` when the plugin's 'Encoding method' is set to 'hashids', producing only ~101 possible values (~7 bits of entropy); the resulting token is a reversible Hashids encoding with no cryptographic MAC, and the unauthenticated `verify()` handler — hooked to `init` at `PHP_INT_MAX` with no nonce check and no rate limiting — accepts and acts on the attacker-controlled `?alg_wc_ev_verify_email=` GET parameter directly. This makes it possible for unauthenticated attackers to gain authentication as any unverified WordPress account, including administrator-level accounts, by brute-forcing the trivially small activation code space via a forged verification URL. Exploitation requires that the 'Encoding method' setting be changed to 'hashids' (non-default), that the attacker recover or brute-force the Hashids salt (which defaults to an `md5(time())` value set at first initialization), and that the target account's email address remain unverified.

NVD CVE-2026-104745Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2024-13525 · published 2025-02-15

Information disclosure in Customer Email Verification for WooCommerce (2.9.4 and older)

Affected
2.9.4 and older
Fixed in
2.9.5 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Customer Email Verification for WooCommerce plugin for WordPress is vulnerable to Sensitive Information Exposure in all versions up to, and including, 2.9.4 via Shortcode. This makes it possible for authenticated attackers, with Contributor-level access and above, to extract sensitive data including emails as well as hashed passwords of any user.

NVD CVE-2024-13525Wordfence advisoryCode change (fix)Plugin source

high 7.5 CVE-2024-13528 · published 2025-02-12

Authentication bypass in Customer Email Verification for WooCommerce (2.9.5 and older)

Affected
2.9.5 and older
Fixed in
2.9.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Customer Email Verification for WooCommerce plugin for WordPress is vulnerable to Authentication Bypass in all versions up to, and including, 2.9.5. This is due to the presence of a shortcode that will generate a confirmation link with a placeholder email. This makes it possible for authenticated attackers, with Contributor-level access and above, to generate a verification link for any unverified user and log into the account. The 'Fine tune placement' option must be enabled in the plugin settings in order to exploit the vulnerability.

NVD CVE-2024-13528Wordfence advisoryCode change (fix)Plugin source

critical 9.3 CVE-2024-49305 · published 2024-10-17

SQL injection in Customer Email Verification for WooCommerce (2.8.10 and older)

Affected
2.8.10 and older
Fixed in
2.9.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in WPFactory Email Verification for WooCommerce emails-verification-for-woocommerce allows SQL Injection.This issue affects Email Verification for WooCommerce: from n/a through <= 2.8.10.

NVD CVE-2024-49305Patchstack advisory

high 8.1 CVE-2024-4185 · published 2024-04-30

Authentication bypass in Customer Email Verification for WooCommerce (2.7.4 and older)

Affected
2.7.4 and older
Fixed in
2.7.5 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Customer Email Verification for WooCommerce plugin for WordPress is vulnerable to Email Verification and Authentication Bypass in all versions up to, and including, 2.7.4 via the use of insufficiently random activation code. This makes it possible for unauthenticated attackers to bypass the email verification, and if both the "Login the user automatically after the account is verified" and "Verify account for current users" options are checked, then it potentially makes it possible for attackers to bypass authentication for other users.

NVD CVE-2024-4185Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Customer Email Verification for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/emails-verification-for-woocommerce"><img src="https://laskyr.com/plugins/emails-verification-for-woocommerce/badge.svg" alt="Customer Email Verification for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit