Skip to content
Laskyr

Plugins · emailkit · data as of 2026-11-04

Is EmailKit safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.7.0)

As of 2026-11-04. 5 issues are on record for older versions; version 1.6.6 or newer fixes all of them that state a fix.

Latest version
1.7.0
Last updated
2026-11-03
Active installs
70,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

EmailKit is a powerful WordPress and WooCommerce email customizer tool, free for everyone! It allows users to customize and design templates that show … — by Roxnor

What to do

  1. Update to the latest version (1.7.0). Anything older than 1.6.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get emailkit --field=version shows what you run; wp plugin update emailkit updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-5957 · published 2026-05-05

Path traversal / file read in EmailKit (1.6.5 and older)

Affected
1.6.5 and older
Fixed in
1.6.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The EmailKit plugin for WordPress is vulnerable to Arbitrary File Read in all versions up to and including 1.6.5. This is due to a flawed path traversal validation in the create_template() method of the CheckForm class, where realpath() is called on the allowed base directory (wp-content/uploads/emailkit/templates/) which may not exist, causing it to return false. In PHP 8.x, strpos($real_path, false) implicitly converts false to an empty string, and strpos() with an empty needle always returns 0, causing the check strpos(...) !== 0 to evaluate to false and bypassing the path validation entirely. This makes it possible for authenticated attackers, with Author-level access and above, to read arbitrary files from the server, including sensitive files such as wp-config.php, by supplying an absolute path to the emailkit-editor-template REST API parameter.

NVD CVE-2026-5957Wordfence advisoryCode change (fix)Plugin source

medium 4.9 CVE-2026-3474 · published 2026-03-21

Path traversal / file read in EmailKit (1.6.3 and older)

Affected
1.6.3 and older
Fixed in
1.6.4 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The EmailKit – Email Customizer for WooCommerce & WP plugin for WordPress is vulnerable to arbitrary file read via path traversal in all versions up to, and including, 1.6.3. This is due to the action() function in the TemplateData class passing user-supplied input from the 'emailkit-editor-template' REST API parameter directly to file_get_contents() without any path validation, sanitization, or restriction to an allowed directory. This makes it possible for authenticated attackers, with Administrator-level access, to read arbitrary files on the server (such as /etc/passwd or wp-config.php) by supplying a traversal path. The file contents are stored as post meta and can subsequently be retrieved via the fetch-data REST API endpoint. Notably, the CheckForm class in the same plugin implements proper path validation using realpath() and directory restriction, demonstrating that the developer was aware of the risk but failed to apply the same protections to the TemplateData endpoint.

NVD CVE-2026-3474Wordfence advisoryCode change (fix)Plugin source

medium 4.3 CVE-2026-1925 · published 2026-02-18

Missing authorization check in EmailKit (1.6.2 and older)

Affected
1.6.2 and older
Fixed in
1.6.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The EmailKit – Email Customizer for WooCommerce & WP plugin for WordPress is vulnerable to unauthorized data modification due to a missing capability check on the 'update_template_data' function in all versions up to, and including, 1.6.2. This makes it possible for authenticated attackers, with Subscriber-level access and above, to modify the title of any post on the site, including posts, pages, and custom post types.

NVD CVE-2026-1925Wordfence advisoryCode change (fix)Plugin source

medium 6.5 CVE-2025-14059 · published 2026-01-07

Path traversal / file read in EmailKit (1.6.1 and older)

Affected
1.6.1 and older
Fixed in
1.6.2 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The EmailKit plugin for WordPress is vulnerable to Arbitrary File Read via Path Traversal in all versions up to, and including, 1.6.1. This is due to missing path validation in the create_template REST API endpoint where user-controlled input from the emailkit-editor-template parameter is passed directly to file_get_contents() without sanitization. This makes it possible for authenticated attackers with Author-level permissions or higher to read arbitrary files on the server, including sensitive configuration files like /etc/passwd and wp-config.php, via the REST API. The file contents are stored in post meta and can be exfiltrated through MetForm's email confirmation feature.

NVD CVE-2025-14059Wordfence advisoryCode change (fix)Plugin source

medium 4.9 CVE-2025-60106 · published 2025-09-26

Missing authorization check in EmailKit (1.6.0 and older)

Affected
1.6.0 and older
Fixed in
1.6.1
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Roxnor EmailKit emailkit allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects EmailKit: from n/a through <= 1.6.0.

NVD CVE-2025-60106Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
EmailKit vulnerability status badge
<a href="https://laskyr.com/plugins/emailkit"><img src="https://laskyr.com/plugins/emailkit/badge.svg" alt="EmailKit vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit