Plugins · email-templates · data as of 2026-11-04
Is Email Templates Customizer and Designer for Wo… safe? Known vulnerabilities and latest version
- Latest version
- 1.5.15
- Last updated
- 2026-10-28
- Active installs
- 20,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.1+
Design and send custom emails with Email Templates plugin for WordPress and WooCommerce — by Saad Iqbal
What to do
- Update to the latest version (1.5.15). Anything older than 1.5.15 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get email-templates --field=version shows what you run; wp plugin update email-templates updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2026-107630 · published 2026-10-30
Missing authorization check in Email Templates Customizer and Designer for Wo… (1.5.14 and older)
- Affected
- 1.5.14 and older
- Fixed in
- 1.5.15 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Email Templates Customizer and Designer for WordPress and WooCommerce plugin for WordPress is vulnerable to authorization bypass in all versions up to, and including, 1.5.14 This is due to the plugin not properly verifying that a user is authorized to perform an action. This makes it possible for unauthenticated attackers to enumerate WooCommerce order IDs via the preview_order parameter and exfiltrate every customer's billing name, address, phone number, and email address. The exploit requires two unauthenticated requests: the first harvests a reusable nonce from the 302 Location header returned by the unguarded admin_init handler, and the second supplies that nonce alongside an arbitrary order ID to the preview endpoint, making full customer PII disclosure trivially achievable without any account or credentials.
NVD CVE-2026-107630Wordfence advisoryCode change (fix)Plugin source
high 8.8 CVE-2022-47181 · published 2023-11-07
Cross-site request forgery (CSRF) in Email Templates Customizer and Designer for Wo… (1.4.2 and older)
- Affected
- 1.4.2 and older
- Fixed in
- 1.4.3
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in wpexpertsio Email Templates Customizer and Designer for WordPress and WooCommerce email-templates allows Cross Site Request Forgery.This issue affects Email Templates Customizer and Designer for WordPress and WooCommerce: from n/a through 1.4.2.
high 8.8 CVE-2019-25150 · published 2023-06-07
Cross-site request forgery (CSRF) in Email Templates Customizer and Designer for Wo… (1.3 and older)
- Affected
- 1.3 and older
- Fixed in
- 1.3.1 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Email Templates plugin for WordPress is vulnerable to HTML Injection in versions up to, and including, 1.3. This makes it possible for attackers to present phishing forms or conduct cross-site request forgery attacks against site administrators.
NVD CVE-2019-25150Wordfence advisorywordpress.orgblog.nintechnet.com
Recent activity
- 2026-10-28 — latest release on wordpress.org (1.5.15).
- 2026-10-30 — Missing authorization check disclosed (CVE-2026-107630), fixed in 1.5.15.
- 2023-11-07 — Cross-site request forgery (CSRF) disclosed (CVE-2022-47181), fixed in 1.4.3.
- 2023-06-07 — Cross-site request forgery (CSRF) disclosed (CVE-2019-25150), fixed in 1.3.1.
Get an email when Email Templates Customizer and Designer for Wo… has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Email Templates Customizer and Designer for Wo… (email-templates) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Saad Iqbal (16 tracked)
Types found in this plugin: Cross-site request forgery (CSRF) (2) · Missing authorization (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/email-templates (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/email-templates"><img src="https://laskyr.com/plugins/email-templates/badge.svg" alt="Email Templates Customizer and Designer for Wo… vulnerability status"></a>