Plugins · email-subscription-with-secure-captcha · data as of 2026-11-04
Is Easy Email Subscription safe? Known vulnerabilities and latest version
- Latest version
- 1.3.1
- Last updated
- 2025-11-03
- Active installs
- 10+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 6.8.12 · PHP 5.6+
Easy Email Subscription form with secured captcha. — by Yudiz Solutions Ltd.
What to do
- Update to the latest version (1.3.1). Anything older than 1.3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get email-subscription-with-secure-captcha --field=version shows what you run; wp plugin update email-subscription-with-secure-captcha updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2025-11994 · published 2025-11-12
Stored cross-site scripting (XSS) in Easy Email Subscription (1.3 and older)
- Affected
- 1.3 and older
- Fixed in
- 1.3.1 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Easy Email Subscription plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'name' parameter in all versions up to, and including, 1.3 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2025-11994Wordfence advisoryCode change (fix)plugins.svn.wordpress.orgplugins.svn.wordpress.org
medium 4.3 CVE-2025-10691 · published 2025-11-06
Cross-site request forgery (CSRF) in Easy Email Subscription (1.3 and older)
- Affected
- 1.3 and older
- Fixed in
- 1.3.1 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Easy Email Subscription plugin for WordPress is vulnerable to Cross-Site Request Forgery in all versions up to, and including, 1.3. This is due to missing or incorrect nonce validation on the show_editsub_page() function. This makes it possible for unauthenticated attackers to delete arbitrary subscribers via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
medium 4.9 CVE-2025-10683 · published 2025-11-06
SQL injection in Easy Email Subscription (1.3 and older)
- Affected
- 1.3 and older
- Fixed in
- 1.3.1 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Easy Email Subscription plugin for WordPress is vulnerable to SQL Injection via the 'uid' parameter in all versions up to, and including, 1.3 due to insufficient escaping on the user supplied parameter and lack of sufficient preparation on the existing SQL query. This makes it possible for authenticated attackers, with Administrator-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.
Recent activity
- 2025-11-03 — latest release on wordpress.org (1.3.1).
- 2025-11-12 — Stored cross-site scripting (XSS) disclosed (CVE-2025-11994), fixed in 1.3.1.
- 2025-11-06 — Cross-site request forgery (CSRF) disclosed (CVE-2025-10691), fixed in 1.3.1.
- 2025-11-06 — SQL injection disclosed (CVE-2025-10683), fixed in 1.3.1.
Get an email when Easy Email Subscription has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Easy Email Subscription (email-subscription-with-secure-captcha) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Yudiz Solutions Ltd. (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1) · Cross-site request forgery (CSRF) (1) · SQL injection (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/email-subscription-with-secure-captcha (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/email-subscription-with-secure-captcha"><img src="https://laskyr.com/plugins/email-subscription-with-secure-captcha/badge.svg" alt="Easy Email Subscription vulnerability status"></a>