Skip to content
Laskyr

Plugins · email-customizer-for-woocommerce · data as of 2026-11-04

Is Email Customizer for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.7.1)

As of 2026-11-04. 2 issues are on record for older versions; version 2.6.8 or newer fixes all of them that state a fix.

Latest version
2.7.1
Last updated
2026-08-19
Active installs
9,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

WooCommerce Email Customizer plugin lets you customize transactional emails using a template builder, adding text, images & more to match your brand — by ThemeHigh

What to do

  1. Update to the latest version (2.7.1). Anything older than 2.6.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get email-customizer-for-woocommerce --field=version shows what you run; wp plugin update email-customizer-for-woocommerce updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.4 CVE-2025-13974 · published 2026-01-07

Stored cross-site scripting (XSS) in Email Customizer for WooCommerce (2.6.7 and older)

Affected
2.6.7 and older
Fixed in
2.6.8 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Email Customizer for WooCommerce plugin for WordPress is vulnerable to Stored Cross-Site Scripting via email template content in all versions up to, and including, 2.6.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access, to inject arbitrary web scripts in email templates that will execute when customers view transactional emails. This only affects multi-site installations and installations where unfiltered_html has been disabled.

NVD CVE-2025-13974Wordfence advisoryCode change (fix)Plugin source

high 7.5 CVE-2024-32781 · published 2024-04-24

Information disclosure in Email Customizer for WooCommerce (2.6.0 and older)

Affected
2.6.0 and older
Fixed in
2.6.1
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Exposure of Sensitive Information to an Unauthorized Actor vulnerability in ThemeHigh Email Customizer for WooCommerce.This issue affects Email Customizer for WooCommerce: from n/a through 2.6.0.

NVD CVE-2024-32781Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Email Customizer for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/email-customizer-for-woocommerce"><img src="https://laskyr.com/plugins/email-customizer-for-woocommerce/badge.svg" alt="Email Customizer for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit