Skip to content
Laskyr

Plugins · element-camp · data as of 2026-11-04

Is ElementCamp safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.3.8)

As of 2026-11-04. 2 issues are on record for older versions; version 2.3.8 or newer fixes all of them that state a fix.

Latest version
2.3.8
Last updated
2026-04-22
Active installs
1,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.4+

ElementCamp is an Elementor addon plugin that provides custom widgets to enhance your website-building experience. — by wpdive

What to do

  1. Update to the latest version (2.3.8). Anything older than 2.3.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get element-camp --field=version shows what you run; wp plugin update element-camp updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-2503 · published 2026-03-21

SQL injection in ElementCamp (2.3.6 and older)

Affected
2.3.6 and older
Fixed in
2.3.8 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The ElementCamp plugin for WordPress is vulnerable to time-based SQL Injection via the 'meta_query[compare]' parameter in the 'tcg_select2_search_post' AJAX action in all versions up to, and including, 2.3.6. This is due to the user-supplied compare value being placed as an SQL operator in the query without validation against an allowlist of comparison operators. The value is passed through esc_sql(), but since the payload operates as an operator (not inside quotes), esc_sql() has no effect on payloads that don't contain quote characters. This makes it possible for authenticated attackers, with Author-level access and above, to append additional SQL queries into already existing queries that can be used to extract sensitive information from the database.

NVD CVE-2026-2503Wordfence advisoryPlugin source

medium 5.3 CVE-2026-24556 · published 2026-01-23

Missing authorization check in ElementCamp (2.3.2 and older)

Affected
2.3.2 and older
Fixed in
2.3.6
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in wpdive ElementCamp element-camp allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects ElementCamp: from n/a through <= 2.3.2.

NVD CVE-2026-24556Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
ElementCamp vulnerability status badge
<a href="https://laskyr.com/plugins/element-camp"><img src="https://laskyr.com/plugins/element-camp/badge.svg" alt="ElementCamp vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit