Plugins · elegance-menu · data as of 2026-11-04
Is Elegance Menu safe? Known vulnerabilities and latest version
- Latest version
- 1.9.1
- Last updated
- 2025-12-03
- Active installs
- 60+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11
Elegant Menu plugin designed to display for a variety of businesses, including restaurants, cafes, fast food outlets, coffee houses, salons, and more. — by impacttechlab
What to do
- Update to the latest version (1.9.1). Anything older than 1.9.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get elegance-menu --field=version shows what you run; wp plugin update elegance-menu updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.5 CVE-2025-11704 · published 2025-11-04
File inclusion in Elegance Menu (1.9 and older)
- Affected
- 1.9 and older
- Fixed in
- 1.9.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Elegance Menu plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 1.9 via the 'elegance-menu' attribute of the `elegance-menu` shortcode. This makes it possible for authenticated attackers, with Contributor-level access and above, to include and execute arbitrary .php files on the server, allowing the execution of any PHP code in those files. This can be used to bypass access controls, obtain sensitive data, or achieve code execution in cases where .php file types can be uploaded and included.
NVD CVE-2025-11704Wordfence advisoryCode change (fix)wordpress.orgPlugin source
Recent activity
- 2025-12-03 — latest release on wordpress.org (1.9.1).
- 2025-11-04 — File inclusion disclosed (CVE-2025-11704), fixed in 1.9.1.
Get an email when Elegance Menu has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Elegance Menu (elegance-menu) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: File inclusion (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/elegance-menu (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/elegance-menu"><img src="https://laskyr.com/plugins/elegance-menu/badge.svg" alt="Elegance Menu vulnerability status"></a>