Plugins · ele-blog · data as of 2026-11-04
Is Eleblog safe? Known vulnerabilities and latest version
- Latest version
- 1.9
- Last updated
- 2026-05-20
- Active installs
- 1,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 5.0+
Eleblog is an ultimate posts addon or element pack for the Elementor page builder. You can display the blog posts on the WordPress web site the way... — by SolverWp
What to do
- Update to the latest version (1.9). Anything older than 1.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get ele-blog --field=version shows what you run; wp plugin update ele-blog updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 1 record(s) do not state which versions are affected.
high 8.1 CVE-2025-69374 · published 2026-02-20
File inclusion in Eleblog (2.0.3 and older)
- Affected
- 2.0.3 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Note: the source's version range goes past the newest Eleblog release on wordpress.org (1.9), so it probably describes a paid edition with its own version numbers, or contains a typo. We do not use it to judge your version.
Details from the advisory
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in SolverWp Eleblog – Elementor Blog And Magazine Addons ele-blog allows PHP Local File Inclusion.This issue affects Eleblog – Elementor Blog And Magazine Addons: from n/a through <= 2.0.3.
medium 4.3 CVE-2024-10663 · published 2024-12-04
Missing authorization check in Eleblog (1.8 and older)
- Affected
- 1.8 and older
- Fixed in
- 1.9 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Eleblog – Elementor Blog And Magazine Addons plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the goodbye_form_callback() function in all versions up to, and including, 1.8. This makes it possible for authenticated attackers, with Subscriber-level access and above, to submit a deactivation reason.
medium 6.5 CVE-2024-33945 · published 2024-05-03
Stored cross-site scripting (XSS) in Eleblog (1.8 and older)
- Affected
- 1.8 and older
- Fixed in
- 1.9 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in solverwp.Com Eleblog – Elementor Blog And Magazine Addons allows Stored XSS.This issue affects Eleblog – Elementor Blog And Magazine Addons: from n/a through 1.8.
Recent activity
- 2026-05-20 — latest release on wordpress.org (1.9).
- 2026-02-20 — File inclusion disclosed (CVE-2025-69374), fix version not stated.
- 2024-12-04 — Missing authorization check disclosed (CVE-2024-10663), fixed in 1.9.
- 2024-05-03 — Stored cross-site scripting (XSS) disclosed (CVE-2024-33945), fixed in 1.9.
Get an email when Eleblog has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Eleblog (ele-blog) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: File inclusion (1) · Missing authorization (1) · Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/ele-blog (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/ele-blog"><img src="https://laskyr.com/plugins/ele-blog/badge.svg" alt="Eleblog vulnerability status"></a>