Plugins · elasticpress · data as of 2026-11-04
Is ElasticPress safe? Known vulnerabilities and latest version
- Latest version
- 5.3.5
- Last updated
- 2026-09-10
- Active installs
- 8,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
A fast and flexible search and query engine for WordPress. — by 10up
What to do
- Update to the latest version (5.3.5). Anything older than 5.3.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get elasticpress --field=version shows what you run; wp plugin update elasticpress updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-62088 · published 2026-09-11
Information disclosure in ElasticPress (5.3.4 and older)
- Affected
- 5.3.4 and older
- Fixed in
- 5.3.5
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Insertion of Sensitive Information Into Sent Data vulnerability in 10up ElasticPress allows Retrieve Embedded Sensitive Data. This issue affects ElasticPress: from n/a through 5.3.4.
medium 4.3 CVE-2024-35684 · published 2024-06-08
Cross-site request forgery (CSRF) in ElasticPress (5.1.1 and older)
- Affected
- 5.1.1 and older
- Fixed in
- 5.1.2
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in 10up ElasticPress elasticpress.This issue affects ElasticPress: from n/a through <= 5.1.1.
medium 4.3 CVE-2021-4405 · published 2023-07-01
Cross-site request forgery (CSRF) in ElasticPress (3.5.3 and older)
- Affected
- 3.5.3 and older
- Fixed in
- 3.5.4 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The ElasticPress plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 3.5.3. This is due to missing or incorrect nonce validation on the epio_send_autosuggest_allowed() function. This makes it possible for unauthenticated attackers to send allowed parameters for autosuggest to elasticpress[.]io via a forged request granted they can trick a site administrator into performing an action such as clicking on a link.
NVD CVE-2021-4405Wordfence advisoryCode change (fix)blog.nintechnet.comblog.nintechnet.comblog.nintechnet.comblog.nintechnet.com
Recent activity
- 2026-09-10 — latest release on wordpress.org (5.3.5).
- 2026-09-11 — Information disclosure disclosed (CVE-2026-62088), fixed in 5.3.5.
- 2024-06-08 — Cross-site request forgery (CSRF) disclosed (CVE-2024-35684), fixed in 5.1.2.
- 2023-07-01 — Cross-site request forgery (CSRF) disclosed (CVE-2021-4405), fixed in 3.5.4.
Get an email when ElasticPress has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for ElasticPress (elasticpress) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by 10up (5 tracked)
Types found in this plugin: Cross-site request forgery (CSRF) (2) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/elasticpress (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/elasticpress"><img src="https://laskyr.com/plugins/elasticpress/badge.svg" alt="ElasticPress vulnerability status"></a>