Skip to content
Laskyr

Plugins · elastic-email-sender · data as of 2026-11-04

Is Elastic Email Sender safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.22)

As of 2026-11-04. 2 issues are on record for older versions; version 1.2.21 or newer fixes all of them that state a fix.

Latest version
1.2.22
Last updated
2025-12-03
Active installs
10,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
6.9.11 · PHP 7.0+

Reconfigures wp_mail() to send email using Elastic Email API instead of SMTP. — by Elastic Email

What to do

  1. Update to the latest version (1.2.22). Anything older than 1.2.21 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get elastic-email-sender --field=version shows what you run; wp plugin update elastic-email-sender updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2025-66525 · published 2025-12-09

Missing authorization check in Elastic Email Sender (1.2.20 and older)

Affected
1.2.20 and older
Fixed in
1.2.21
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Elastic Email Elastic Email Sender elastic-email-sender allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Elastic Email Sender: from n/a through <= 1.2.20.

NVD CVE-2025-66525Patchstack advisory

medium 4.8 CVE-2023-38387 · published 2023-09-03

Stored cross-site scripting (XSS) in Elastic Email Sender (1.2.6 and older)

Affected
1.2.6 and older
Fixed in
1.2.7
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Elastic Email Sender plugin <= 1.2.6 versions.

NVD CVE-2023-38387Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Elastic Email Sender vulnerability status badge
<a href="https://laskyr.com/plugins/elastic-email-sender"><img src="https://laskyr.com/plugins/elastic-email-sender/badge.svg" alt="Elastic Email Sender vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit