Plugins · eds-font-awesome · data as of 2026-11-04
Is Ed's Font Awesome safe? Known vulnerabilities and latest version
- Latest version
- 3.0.1
- Last updated
- 2026-05-09
- Active installs
- fewer than 10
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11 · PHP 7.0+
Ed's Font Awesome Plugin is the ultimate Font Awesome Icon Shortcode plugin with 2,000+ icons, animations, layers, and color support. — by waianaeboy702
What to do
- Update to the latest version (3.0.1). Anything older than 2.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get eds-font-awesome --field=version shows what you run; wp plugin update eds-font-awesome updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-2496 · published 2026-03-21
Stored cross-site scripting (XSS) in Ed's Font Awesome (2.0 and older)
- Affected
- 2.0 and older
- Fixed in
- 2.1 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Ed's Font Awesome plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's `eds_font_awesome` shortcode in all versions up to, and including, 2.0. This is due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-2496Wordfence advisorywordpress.orgPlugin source
Recent activity
- 2026-05-09 — latest release on wordpress.org (3.0.1).
- 2026-03-21 — Stored cross-site scripting (XSS) disclosed (CVE-2026-2496), fixed in 2.1.
Get an email when Ed's Font Awesome has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Ed's Font Awesome (eds-font-awesome) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by waianaeboy702 (2 tracked)
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/eds-font-awesome (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/eds-font-awesome"><img src="https://laskyr.com/plugins/eds-font-awesome/badge.svg" alt="Ed's Font Awesome vulnerability status"></a>