Skip to content
Laskyr

Plugins · editorial-rating · data as of 2026-11-04

Is Editorial Rating safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.0.6)

As of 2026-11-04. 1 issue is on record for older versions; version 4.0.6 or newer fixes all of them that state a fix.

Latest version
4.0.6
Last updated
2026-06-28
Active installs
200+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8

Add multi-criteria product reviews and star ratings to WordPress posts. Boost engagement, SEO, and sales with editorial ratings. — by Pluginic

What to do

  1. Update to the latest version (4.0.6). Anything older than 4.0.6 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get editorial-rating --field=version shows what you run; wp plugin update editorial-rating updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.4 CVE-2026-12560 · published 2026-06-30

Stored cross-site scripting (XSS) in Editorial Rating (4.0.5 and older)

Affected
4.0.5 and older
Fixed in
4.0.6 *
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Editorial Rating – Product Review & Rating System plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'Link URL' Field in all versions up to, and including, 4.0.5 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with administrator-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. The WordPress unfiltered_html capability exemption does not apply here because the payload is stored in post meta (_wpas_er_options via update_post_meta) rather than in post_content or post_excerpt, meaning the restriction affects all administrators regardless of their unfiltered_html status.

NVD CVE-2026-12560Wordfence advisoryPlugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Editorial Rating vulnerability status badge
<a href="https://laskyr.com/plugins/editorial-rating"><img src="https://laskyr.com/plugins/editorial-rating/badge.svg" alt="Editorial Rating vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit