Plugins · editorial-calendar · data as of 2026-11-04
Is Editorial Calendar safe? Known vulnerabilities and latest version
- Latest version
- 3.9.4
- Last updated
- 2026-05-26
- Active installs
- 20,000+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4+
Editorial Calendar allows you to view all your posts, schedule post, make quick edits, and manage your blog by dragging and dropping posts. — by Marketing Fire
What to do
- Update to the latest version (3.9.4). Anything older than 3.9.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get editorial-calendar --field=version shows what you run; wp plugin update editorial-calendar updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.5 CVE-2026-32361 · published 2026-03-13
Cross-site scripting (XSS) in Editorial Calendar (3.9.0 and older)
- Affected
- 3.9.0 and older
- Fixed in
- 3.9.1
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Marketing Fire Editorial Calendar editorial-calendar allows DOM-Based XSS.This issue affects Editorial Calendar: from n/a through <= 3.9.0.
medium 5.4 CVE-2025-68603 · published 2025-12-24
Missing authorization check in Editorial Calendar (3.8.8 and older)
- Affected
- 3.8.8 and older
- Fixed in
- 3.8.9
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Marketing Fire Editorial Calendar editorial-calendar allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Editorial Calendar: from n/a through <= 3.8.8.
high 8.1 CVE-2023-36520 · published 2023-12-20
Missing authorization check in Editorial Calendar (3.7.12 and older)
- Affected
- 3.7.12 and older
- Fixed in
- 3.8.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Authorization Bypass Through User-Controlled Key vulnerability in MarketingFire Editorial Calendar.This issue affects Editorial Calendar: from n/a through 3.7.12.
medium 5.4 CVE-2022-4115 · published 2023-06-27
Stored cross-site scripting (XSS) in Editorial Calendar (older than 3.8.3)
- Affected
- older than 3.8.3
- Fixed in
- 3.8.3
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Editorial Calendar WordPress plugin before 3.8.3 does not sanitise and escape its settings, allowing users with roles as low as contributor to inject arbitrary web scripts in the plugin admin panel, enabling a Stored Cross-Site Scripting vulnerability targeting higher privileged users.
Recent activity
- 2026-05-26 — latest release on wordpress.org (3.9.4).
- 2026-03-13 — Cross-site scripting (XSS) disclosed (CVE-2026-32361), fixed in 3.9.1.
- 2025-12-24 — Missing authorization check disclosed (CVE-2025-68603), fixed in 3.8.9.
- 2023-12-20 — Missing authorization check disclosed (CVE-2023-36520), fixed in 3.8.0.
Get an email when Editorial Calendar has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Editorial Calendar (editorial-calendar) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Marketing Fire (3 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (2)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/editorial-calendar (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/editorial-calendar"><img src="https://laskyr.com/plugins/editorial-calendar/badge.svg" alt="Editorial Calendar vulnerability status"></a>