Skip to content
Laskyr

Plugins · ecpay-ecommerce-for-woocommerce · data as of 2026-11-04

Is ECPay Ecommerce for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.2610151)

As of 2026-11-04. 2 issues are on record for older versions; version 1.1.2610150 or newer fixes all of them that state a fix.

Latest version
1.1.2610151
Last updated
2026-10-16
Active installs
2,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 8.2+

綠界科技外掛套件,提供合作特店以及個人賣家使用開放原始碼商店系統時,無須自行處理複雜的檢核,直接透過安裝設定外掛套件,便可快速介接綠界科技系統,進行金流、物流、電子發票操作。 — by techsupport

What to do

  1. Update to the latest version (1.1.2610151). Anything older than 1.1.2610150 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ecpay-ecommerce-for-woocommerce --field=version shows what you run; wp plugin update ecpay-ecommerce-for-woocommerce updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-32578 · published 2026-10-06

Missing authorization check in ECPay Ecommerce for WooCommerce (1.1.2606090 and older)

Affected
1.1.2606090 and older
Fixed in
1.1.2610150 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Subscriber Broken Access Control in ECPay Ecommerce for WooCommerce <= 1.1.2606090 versions.

NVD CVE-2026-32578Patchstack advisory

medium 4.3 CVE-2024-13652 · published 2025-01-30

Missing authorization check in ECPay Ecommerce for WooCommerce (1.1.2411060 and older)

Affected
1.1.2411060 and older
Fixed in
1.1.2502030 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The ECPay Ecommerce for WooCommerce plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the 'clear_ecpay_debug_log' AJAX action in all versions up to, and including, 1.1.2411060. This makes it possible for authenticated attackers, with Subscriber-level access and above, to clear the plugin's log files.

NVD CVE-2024-13652Wordfence advisoryCode change (fix)wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
ECPay Ecommerce for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/ecpay-ecommerce-for-woocommerce"><img src="https://laskyr.com/plugins/ecpay-ecommerce-for-woocommerce/badge.svg" alt="ECPay Ecommerce for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit