Skip to content
Laskyr

Plugins · ecommerce-user-profiles-by-profilegrid · data as of 2026-11-04

Is Memberships and User Profiles for WooCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.4.1)

As of 2026-11-04. 1 issue is on record for older versions; version 3.4.1 or newer fixes all of them that state a fix.

Latest version
3.4.1
Last updated
2026-07-01
Active installs
300+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.0.8

Sell more on WooCommerce with modern user profiles, user activities, content restriction, groups, paid memberships, and social commerce. — by Metagauss

What to do

  1. Update to the latest version (3.4.1). Anything older than 3.4.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get ecommerce-user-profiles-by-profilegrid --field=version shows what you run; wp plugin update ecommerce-user-profiles-by-profilegrid updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-11359 · published 2026-07-09

Missing authorization check in Memberships and User Profiles for WooCommerce (3.4 and older)

Affected
3.4 and older
Fixed in
3.4.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Memberships and User Profiles for WooCommerce – ProfileGrid WooCommerce Integration plugin for WordPress is vulnerable to unauthorized plugin installation and activation in versions up to, and including, 3.4. This is due to a missing capability check and missing nonce validation on the pg_install_profilegrid() AJAX handler registered via wp_ajax_pg_install_profilegrid. This makes it possible for authenticated attackers, with Subscriber-level access and above, to install and activate the ProfileGrid plugin from wordpress.

NVD CVE-2026-11359Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Memberships and User Profiles for WooCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/ecommerce-user-profiles-by-profilegrid"><img src="https://laskyr.com/plugins/ecommerce-user-profiles-by-profilegrid/badge.svg" alt="Memberships and User Profiles for WooCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit