Skip to content
Laskyr

Plugins · echo-knowledge-base · data as of 2026-11-04

Is Echo Knowledge Base safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (17.311.1)

As of 2026-11-04. 4 issues are on record for older versions; version 17.311.0 or newer fixes all of them that state a fix.

Latest version
17.311.1
Last updated
2026-10-17
Active installs
10,000+
Known issues on record
4
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6+

A fully featured, easy-to-use documentation plugin with AI chat, search, FAQs, and quizzes. Build beautiful knowledge bases, docs, and wikis. — by echoplugins

What to do

  1. Update to the latest version (17.311.1). Anything older than 17.311.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get echo-knowledge-base --field=version shows what you run; wp plugin update echo-knowledge-base updates it.

Check your version

Known vulnerabilities

4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.1 CVE-2026-101935 · published 2026-10-28

Reflected cross-site scripting (XSS) in Echo Knowledge Base (17.214.0 and older)

Affected
17.214.0 and older
Fixed in
17.311.0 *
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Echo Knowledge Base – Documentation, FAQs, Chat & Smart Search plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the 'new_kb_config' parameter (specifically the article-mobile-break-point-v2 key, among other config keys interpolated into the <style> element) in versions up to, and including, 17.214.0 This is due to insufficient input sanitization and output escaping in EPKB_Frontend_Editor::fe_preview_config() and EPKB_Articles_Setup: on every knowledge base article page view, when the request supplies epkb_fe_reload_mode=on, an attacker-controlled JSON blob is merged over the stored KB configuration and several values are concatenated directly into a stylesheet emitted inside a literal <style> element without escaping (minify_css() does not strip <, > or /). This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user (with Editor-level access or above, holding the manage_categories capability, or an Administrator) into performing an action such as clicking on a specially crafted link.

NVD CVE-2026-101935Wordfence advisoryCode change (fix)Plugin source

high 7.1 CVE-2026-28187 · published 2026-08-13

Cross-site scripting (XSS) in Echo Knowledge Base (17.211.0 and older)

Affected
17.211.0 and older
Fixed in
17.212.0
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Unauthenticated Cross Site Scripting (XSS) in Knowledge Base for Documentation, FAQs with AI Assistance <= 17.211.0 versions.

NVD CVE-2026-28187Patchstack advisory

medium 4.3 CVE-2026-25402 · published 2026-02-19

Missing authorization check in Echo Knowledge Base (16.011.0 and older)

Affected
16.011.0 and older
Fixed in
16.20.0
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in echoplugins Knowledge Base for Documentation, FAQs with AI Assistance echo-knowledge-base allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Knowledge Base for Documentation, FAQs with AI Assistance: from n/a through <= 16.011.0.

NVD CVE-2026-25402Patchstack advisory

high 8.7 CVE-2024-24842 · published 2024-03-27

PHP object injection in Echo Knowledge Base (11.30.2 and older)

Affected
11.30.2 and older
Fixed in
11.31.0
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Deserialization of Untrusted Data vulnerability in Echo Plugins Knowledge Base for Documentation, FAQs with AI Assistance.This issue affects Knowledge Base for Documentation, FAQs with AI Assistance: from n/a through 11.30.2.

NVD CVE-2024-24842Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Echo Knowledge Base vulnerability status badge
<a href="https://laskyr.com/plugins/echo-knowledge-base"><img src="https://laskyr.com/plugins/echo-knowledge-base/badge.svg" alt="Echo Knowledge Base vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit