Plugins · echbay-admin-security · data as of 2026-11-04
Is EchBay Admin Security safe? Known vulnerabilities and latest version
- Latest version
- 1.3.2
- Last updated
- 2026-07-01
- Active installs
- 100+
- Known issues on record
- 1
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8
Protect Your Website Admin Against Hackers & Modify Login Page Design ( Nhiệm vụ: chặn mọi truy cập trực tiếp vào trang quản trị wordpress dưới dạ … — by Dao Quoc Dai
What to do
- Update to the latest version (1.3.2). Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get echbay-admin-security --field=version shows what you run; wp plugin update echbay-admin-security updates it.
Check your version
Known vulnerabilities
1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.1 CVE-2025-11885 · published 2025-11-21
Reflected cross-site scripting (XSS) in EchBay Admin Security (1.3.0 and older)
- Affected
- 1.3.0 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The EchBay Admin Security plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via the '_ebnonce' parameter in all versions up to, and including, 1.3.0 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.
Recent activity
- 2026-07-01 — latest release on wordpress.org (1.3.2).
- 2025-11-21 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-11885), fix version not stated.
Get an email when EchBay Admin Security has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for EchBay Admin Security (echbay-admin-security) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/echbay-admin-security (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/echbay-admin-security"><img src="https://laskyr.com/plugins/echbay-admin-security/badge.svg" alt="EchBay Admin Security vulnerability status"></a>