Plugins · easyjobs · data as of 2026-11-04
Is easy.jobs safe? Known vulnerabilities and latest version
- Latest version
- 2.8.5
- Last updated
- 2026-10-27
- Active installs
- 4,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Attract, manage & hire the right talent faster. Create job listings, career pages, and manage recruitment with Elementor and the Block Editor. — by WPDeveloper
What to do
- Update to the latest version (2.8.5). Anything older than 2.8.5 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get easyjobs --field=version shows what you run; wp plugin update easyjobs updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.2 CVE-2026-112365 · published 2026-10-30
Stored cross-site scripting (XSS) in easy.jobs (2.8.4 and older)
- Affected
- 2.8.4 and older
- Fixed in
- 2.8.5 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The easy.jobs – AI powered Job Listing, Job Board, Career Page, Recruitment & Hiring Solution plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'cover_letter' parameter in all versions up to, and including, 2.8.4 due to insufficient input sanitization and output escaping. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Successful execution requires an administrator to open the affected candidate's Application tab and click the attacker-crafted link, at which point WHATWG URL parsing collapses the encoded scheme back to javascript: and executes the payload.
NVD CVE-2026-112365Wordfence advisoryCode change (fix)Plugin source
medium 6.4 CVE-2026-108366 · published 2026-10-28
Stored cross-site scripting (XSS) in easy.jobs (2.8.2 and older)
- Affected
- 2.8.2 and older
- Fixed in
- 2.8.3 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The easy.jobs – AI powered Job Listing, Job Board, Career Page, Recruitment & Hiring Solution plugin for WordPress is vulnerable to Authenticated (Contributor+) Stored Cross-Site Scripting via the 'icon' attribute of the easyjobs/job-list Gutenberg block in all versions up to, and including, 2.8.2 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-108366Wordfence advisoryCode change (fix)Plugin source
high 7.1 CVE-2024-43997 · published 2024-10-17
Reflected cross-site scripting (XSS) in easy.jobs (2.4.14 and older)
- Affected
- 2.4.14 and older
- Fixed in
- 2.4.15
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in easy.Jobs EasyJobs allows Reflected XSS.This issue affects EasyJobs: from n/a through 2.4.14.
Recent activity
- 2026-10-27 — latest release on wordpress.org (2.8.5).
- 2026-10-30 — Stored cross-site scripting (XSS) disclosed (CVE-2026-112365), fixed in 2.8.5.
- 2026-10-28 — Stored cross-site scripting (XSS) disclosed (CVE-2026-108366), fixed in 2.8.3.
- 2024-10-17 — Reflected cross-site scripting (XSS) disclosed (CVE-2024-43997), fixed in 2.4.15.
Get an email when easy.jobs has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for easy.jobs (easyjobs) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by WPDeveloper (12 tracked)
Types found in this plugin: Cross-site scripting (XSS) (3)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/easyjobs (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/easyjobs"><img src="https://laskyr.com/plugins/easyjobs/badge.svg" alt="easy.jobs vulnerability status"></a>