Skip to content
Laskyr

Plugins · easycommerce · data as of 2026-11-04

Is EasyCommerce safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.52)

As of 2026-11-04. 1 issue is on record for older versions; version 1.8.3 or newer fixes all of them that state a fix.

Latest version
1.52
Last updated
2026-11-02
Active installs
10+
Known issues on record
1
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Ecommerce for WordPress: online store builder with an AI shopping agent, content writer, image generator, coupons, shipping & tax. — by EasyCommerce

What to do

  1. Update to the latest version (1.52). Anything older than 1.8.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get easycommerce --field=version shows what you run; wp plugin update easycommerce updates it.

Check your version

Known vulnerabilities

1 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.8 CVE-2025-11457 · published 2025-11-11

Privilege escalation in EasyCommerce (1.8.2 and older)

Affected
1.8.2 and older
Fixed in
1.8.3 *
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The EasyCommerce – AI-Powered, Fast & Beautiful WordPress Ecommerce Plugin plugin for WordPress is vulnerable to Privilege Escalation in versions 0.9.0-beta2 to 1.8.2. This is due to the /easycommerce/v1/orders REST API endpoint not properly restricting the ability for users to select roles during registration. This makes it possible for unauthenticated attackers to gain administrator-level access to a vulnerable site.

NVD CVE-2025-11457Wordfence advisoryCode change (fix)wordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
EasyCommerce vulnerability status badge
<a href="https://laskyr.com/plugins/easycommerce"><img src="https://laskyr.com/plugins/easycommerce/badge.svg" alt="EasyCommerce vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit