Plugins · easy-wp-smtp · data as of 2026-11-01
Is Easy WP SMTP safe? Known vulnerabilities and latest version
- Latest version
- 2.15.1
- Last updated
- 2026-08-12
- Active installs
- 500,000+
- Known issues on record
- 8
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
Make SMTP email sending and delivery easy. Configure Gmail SMTP, Outlook, Brevo, SendGrid, Mailgun, SendLayer or connect to any SMTP server. — by Syed Balkhi
What to do
- Update to the latest version (2.15.1). Anything older than 2.3.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get easy-wp-smtp --field=version shows what you run; wp plugin update easy-wp-smtp updates it.
Check your version
Known vulnerabilities
8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
low 2.7 CVE-2024-3073 · published 2024-06-13
Information disclosure in Easy WP SMTP (2.3.0 and older)
- Affected
- 2.3.0 and older
- Fixed in
- 2.3.1 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Easy WP SMTP by SendLayer – WordPress SMTP and Email Log Plugin plugin for WordPress is vulnerable to information exposure in all versions up to, and including, 2.3.0. This is due to plugin providing the SMTP password in the SMTP Password field when viewing the settings. This makes it possible for authenticated attackers, with administrative-level access and above, to view the SMTP password for the supplied server. Although this would not be useful for attackers in most cases, if an administrator account becomes compromised this could be useful information to an attacker in a limited environment.
critical 9.8 CVE-2019-25141 · published 2023-06-07
Missing authorization check in Easy WP SMTP (older than 1.3.9.1)
- Affected
- older than 1.3.9.1
- Fixed in
- 1.3.9.1
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Easy WP SMTP plugin for WordPress is vulnerable to authorization bypass in versions up to, and including, 1.3.9. This is due to missing capability checks on the admin_init() function, in addition to insufficient input validation. This makes it possible for unauthenticated attackers to modify the plugins settings and arbitrary options on the site that can be used to inject new administrative user accounts.
NVD CVE-2019-25141Wordfence advisoryCode change (fix)blog.nintechnet.comwordpress.org
high 8.8 CVE-2022-42699 · published 2022-12-06
Remote code execution in Easy WP SMTP (1.5.1 and older)
- Affected
- 1.5.1 and older
- Fixed in
- 1.5.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. Remote Code Execution vulnerability in Easy WP SMTP plugin <= 1.5.1 on WordPress.
high 8.1 CVE-2022-45829 · published 2022-12-06
Path traversal / file read in Easy WP SMTP (1.5.1 and older)
- Affected
- 1.5.1 and older
- Fixed in
- 1.5.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. Path Traversal vulnerability in Easy WP SMTP plugin <= 1.5.1 at WordPress.
medium 6.5 CVE-2022-45833 · published 2022-12-06
Path traversal / file read in Easy WP SMTP (1.5.1 and older)
- Affected
- 1.5.1 and older
- Fixed in
- 1.5.2
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. Path Traversal vulnerability in Easy WP SMTP plugin <= 1.5.1 on WordPress.
high 7.2 CVE-2022-3334 · published 2022-10-31
PHP object injection in Easy WP SMTP (older than 1.5.0)
- Affected
- older than 1.5.0
- Fixed in
- 1.5.0
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- NVD analysis · score by NVD
Details from the advisory
The Easy WP SMTP WordPress plugin before 1.5.0 unserialises the content of an imported file, which could lead to PHP object injection issue when an admin import (intentionally or not) a malicious file and a suitable gadget chain is present on the blog.
high 7.5 CVE-2020-35234 · published 2020-12-14
Information disclosure in Easy WP SMTP (older than 1.4.4)
- Affected
- older than 1.4.4
- Fixed in
- 1.4.4
- Access needed (per CVSS)
- No login needed
- Range from
- NVD analysis · score by NVD
Details from the advisory
The easy-wp-smtp plugin before 1.4.4 for WordPress allows Administrator account takeover, as exploited in the wild in December 2020. If an attacker can list the wp-content/plugins/easy-wp-smtp/ directory, then they can discover a log file (such as #############_debug_log.txt) that contains all password-reset links. The attacker can request a reset of the Administrator password and then use a link found there.
medium 6.1 CVE-2017-7723 · published 2017-04-24
Cross-site scripting (XSS) in Easy WP SMTP (1.2.4 and older)
- Affected
- 1.2.4 and older
- Fixed in
- 1.2.7 *
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- NVD analysis · score by NVD
Details from the advisory
XSS exists in Easy WP SMTP (before 1.2.5), a WordPress Plugin, via the e-mail subject or body.
Recent activity
- 2026-08-12 — latest release on wordpress.org (2.15.1).
- 2024-06-13 — Information disclosure disclosed (CVE-2024-3073), fixed in 2.3.1.
- 2023-06-07 — Missing authorization check disclosed (CVE-2019-25141), fixed in 1.3.9.1.
- 2022-12-06 — Remote code execution disclosed (CVE-2022-42699), fixed in 1.5.2.
Get an email when Easy WP SMTP has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Easy WP SMTP (easy-wp-smtp) is published or a fix ships. Unsubscribe in one click.
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/easy-wp-smtp (Plugins API), fetched 2026-11-01.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-01. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/easy-wp-smtp"><img src="https://laskyr.com/plugins/easy-wp-smtp/badge.svg" alt="Easy WP SMTP vulnerability status"></a>