Skip to content
Laskyr

Plugins · easy-waveform-player · data as of 2026-11-04

Is Easy Waveform Player safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.2.3)

As of 2026-11-04. 2 issues are on record for older versions; version 1.2.3 or newer fixes all of them that state a fix.

Latest version
1.2.3
Last updated
2026-08-31
Active installs
100+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.0+

Add Waveform players easy and fast to your WordPress. — by tymotey

What to do

  1. Update to the latest version (1.2.3). Anything older than 1.2.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get easy-waveform-player --field=version shows what you run; wp plugin update easy-waveform-player updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2025-7963 · published 2026-09-02

Stored cross-site scripting (XSS) in Easy Waveform Player (1.2.2 and older)

Affected
1.2.2 and older
Fixed in
1.2.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Easy Waveform Player plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the shortcode_easywaveformplayer() function in all versions up to, and including, 1.2.2 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-7963Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 6.4 CVE-2024-11881 · published 2024-12-18

Stored cross-site scripting (XSS) in Easy Waveform Player (1.2.0 and older)

Affected
1.2.0 and older
Fixed in
1.2.1 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Easy Waveform Player plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'easywaveformplayer' shortcode in all versions up to, and including, 1.2.0 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-11881Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Easy Waveform Player vulnerability status badge
<a href="https://laskyr.com/plugins/easy-waveform-player"><img src="https://laskyr.com/plugins/easy-waveform-player/badge.svg" alt="Easy Waveform Player vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit