Skip to content
Laskyr

Plugins · easy-table-of-contents · data as of 2026-11-01

Is Easy Table of Contents safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.89)

As of 2026-11-01. 6 issues are on record for older versions; version 2.0.81 or newer fixes all of them that state a fix.

Latest version
2.0.89
Last updated
2026-10-16
Active installs
600,000+
Known issues on record
6
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 5.6.20+

Adds a user friendly and fully automatic way to create and display a table of contents generated from the page content. — by Magazine3

What to do

  1. Update to the latest version (2.0.89). Anything older than 2.0.81 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get easy-table-of-contents --field=version shows what you run; wp plugin update easy-table-of-contents updates it.

Check your version

Known vulnerabilities

6 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-32343 · published 2026-03-13

Cross-site request forgery (CSRF) in Easy Table of Contents (2.0.80 and older)

Affected
2.0.80 and older
Fixed in
2.0.81
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in Magazine3 Easy Table of Contents easy-table-of-contents allows Cross Site Request Forgery.This issue affects Easy Table of Contents: from n/a through <= 2.0.80.

NVD CVE-2026-32343Patchstack advisory

medium 6.4 CVE-2025-13738 · published 2026-02-19

Stored cross-site scripting (XSS) in Easy Table of Contents (2.0.78 and older)

Affected
2.0.78 and older
Fixed in
2.0.79 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Easy Table of Contents plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's `ez-toc` shortcode in all versions up to, and including, 2.0.78 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-13738Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2023-25469 · published 2024-12-09

Missing authorization check in Easy Table of Contents (2.0.45.2 and older)

Affected
2.0.45.2 and older
Fixed in
2.0.46
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in Magazine3 Easy Table of Contents allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Easy Table of Contents: from n/a through 2.0.45.2.

NVD CVE-2023-25469Patchstack advisory

medium 6.1 CVE-2024-7082 · published 2024-08-06

Cross-site scripting (XSS) in Easy Table of Contents (older than 2.0.68)

Affected
older than 2.0.68
Fixed in
2.0.68
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Easy Table of Contents WordPress plugin before 2.0.68 does not sanitise and escape some parameters, which could allow users with a role as low as Editor to perform Cross-Site Scripting attacks.

NVD CVE-2024-7082WPScan advisory

medium 6.1 CVE-2024-6334 · published 2024-07-09

Cross-site scripting (XSS) in Easy Table of Contents (older than 2.0.67.1)

Affected
older than 2.0.67.1
Fixed in
2.0.67.1
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Easy Table of Contents WordPress plugin before 2.0.67.1 does not sanitise and escape some of its settings, which could allow high privilege users such as editors to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed.

NVD CVE-2024-6334WPScan advisory

medium 5.9 CVE-2024-5573 · published 2024-06-26

Cross-site scripting (XSS) in Easy Table of Contents (older than 2.0.66)

Affected
older than 2.0.66
Fixed in
2.0.66
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Easy Table of Contents WordPress plugin before 2.0.66 does not sanitise and escape some of its settings, which could allow high privilege users such as editors to perform Cross-Site Scripting attacks even when unfiltered_html is disallowed

NVD CVE-2024-5573WPScan advisory

Recent activity

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Easy Table of Contents vulnerability status badge
<a href="https://laskyr.com/plugins/easy-table-of-contents"><img src="https://laskyr.com/plugins/easy-table-of-contents/badge.svg" alt="Easy Table of Contents vulnerability status"></a>

← Check another plugin · Free hacked-site scan

Site hacked? Get help now
Run free scan Fix it now ($499) Send a message

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit