Plugins · easy-svg · data as of 2026-11-04
Is Easy SVG Support safe? Known vulnerabilities and latest version
- Latest version
- 4.2.1
- Last updated
- 2026-10-29
- Active installs
- 40,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.2 · PHP 8.0+
This Plugin allows you to upload SVG Files into your Media library. — by Benjamin Zekavica
What to do
- Update to the latest version (4.2.1). Anything older than 4.1 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get easy-svg --field=version shows what you run; wp plugin update easy-svg updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 4.4 CVE-2025-12451 · published 2026-02-19
Stored cross-site scripting (XSS) in Easy SVG Support (4.0 and older)
- Affected
- 4.0 and older
- Fixed in
- 4.1 *
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Easy SVG Support plugin for WordPress is vulnerable to Stored Cross-Site Scripting via SVG file uploads in all versions up to, and including, 4.0 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.
NVD CVE-2025-12451Wordfence advisoryCode change (fix)Plugin source
medium 5.4 CVE-2024-10269 · published 2024-11-08
Stored cross-site scripting (XSS) in Easy SVG Support (3.7 and older)
- Affected
- 3.7 and older
- Fixed in
- 3.8 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Easy SVG Support plugin for WordPress is vulnerable to Stored Cross-Site Scripting via REST API SVG File uploads in all versions up to, and including, 3.7 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses the SVG file.
NVD CVE-2024-10269Wordfence advisoryCode change (fix)wordpress.org
medium 5.4 CVE-2022-1964 · published 2022-06-27
Cross-site scripting (XSS) in Easy SVG Support (older than 3.3.0)
- Affected
- older than 3.3.0
- Fixed in
- 3.3.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The Easy SVG Support WordPress plugin before 3.3.0 does not sanitise uploaded SVG files, which could allow users with a role as low as Author to upload a malicious SVG containing XSS payloads
Recent activity
- 2026-10-29 — latest release on wordpress.org (4.2.1).
- 2026-02-19 — Stored cross-site scripting (XSS) disclosed (CVE-2025-12451), fixed in 4.1.
- 2024-11-08 — Stored cross-site scripting (XSS) disclosed (CVE-2024-10269), fixed in 3.8.
- 2022-06-27 — Cross-site scripting (XSS) disclosed (CVE-2022-1964), fixed in 3.3.0.
Get an email when Easy SVG Support has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Easy SVG Support (easy-svg) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (3)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/easy-svg (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/easy-svg"><img src="https://laskyr.com/plugins/easy-svg/badge.svg" alt="Easy SVG Support vulnerability status"></a>