Skip to content
Laskyr

Plugins · easy-replace-image · data as of 2026-11-04

Is Easy Replace Image safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (3.5.5)

As of 2026-11-04. 2 issues are on record for older versions; version 3.5.3 or newer fixes all of them that state a fix.

Latest version
3.5.5
Last updated
2026-04-11
Active installs
600+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.0.8 · PHP 7.4+

Replace easily an attachment file by uploading another file or by downloading one from an URL, without deleting the attachment. — by Iulia Cazan

What to do

  1. Update to the latest version (3.5.5). Anything older than 3.5.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get easy-replace-image --field=version shows what you run; wp plugin update easy-replace-image updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 4.3 CVE-2026-1298 · published 2026-01-28

Missing authorization check in Easy Replace Image (3.5.2 and older)

Affected
3.5.2 and older
Fixed in
3.5.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Easy Replace Image plugin for WordPress is vulnerable to Missing Authorization in all versions up to, and including, 3.5.2. This is due to missing capability checks on the `image_replacement_from_url` function that is hooked to the `eri_from_url` AJAX action. This makes it possible for authenticated attackers, with Contributor-level access and above, to replace arbitrary image attachments on the site with images from external URLs, potentially enabling site defacement, phishing attacks, or content manipulation.

NVD CVE-2026-1298Wordfence advisoryCode change (fix)Plugin source

medium 4.9 CVE-2025-47483 · published 2025-05-07

Server-side request forgery (SSRF) in Easy Replace Image (3.5.0 and older)

Affected
3.5.0 and older
Fixed in
3.5.1
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Server-Side Request Forgery (SSRF) vulnerability in Iulia Cazan Easy Replace Image easy-replace-image allows Server Side Request Forgery.This issue affects Easy Replace Image: from n/a through <= 3.5.0.

NVD CVE-2025-47483Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Easy Replace Image vulnerability status badge
<a href="https://laskyr.com/plugins/easy-replace-image"><img src="https://laskyr.com/plugins/easy-replace-image/badge.svg" alt="Easy Replace Image vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit