Skip to content
Laskyr

Plugins · easy-pricing-tables · data as of 2026-11-04

Is Pricing Table WordPress Plugin safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (4.1.3)

As of 2026-11-04. 5 issues are on record for older versions; version 4.1.3 or newer fixes all of them that state a fix.

Latest version
4.1.3
Last updated
2026-09-25
Active installs
10,000+
Known issues on record
5
Unpatched in latest
0
Tested up to WP
7.1.4

Pricing Table Plugin - Easy Pricing Tables Lets You Create A Beautiful, Responsive Pricing Table In 2 Minutes. No Coding Required. — by fatcatapps

What to do

  1. Update to the latest version (4.1.3). Anything older than 4.1.3 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get easy-pricing-tables --field=version shows what you run; wp plugin update easy-pricing-tables updates it.

Check your version

Known vulnerabilities

5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.5 CVE-2026-111947 · published 2026-10-21

Missing authorization check in Pricing Table WordPress Plugin (older than 4.1.3)

Affected
older than 4.1.3
Fixed in
4.1.3
Access needed (per CVSS)
Needs an admin-level account
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Pricing Table WordPress Plugin WordPress plugin before 4.1.3 does not perform authorisation checks when duplicating a legacy pricing table, allowing users with the contributor role and above to clone and publish any post or page on the site, including private and draft content belonging to other users.

NVD CVE-2026-111947WPScan advisory

high 8.5 CVE-2026-94115 · published 2026-09-30

SQL injection in Pricing Table WordPress Plugin (4.1.2 and older)

Affected
4.1.2 and older
Fixed in
4.1.3
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Contributor SQL Injection in Easy Pricing Tables <= 4.1.2 versions.

NVD CVE-2026-94115Patchstack advisory

medium 5.4 CVE-2024-8323 · published 2024-11-06

Stored cross-site scripting (XSS) in Pricing Table WordPress Plugin (3.2.6 and older)

Affected
3.2.6 and older
Fixed in
unknown
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

The Pricing Tables WordPress Plugin – Easy Pricing Tables plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘fontFamily’ attribute in all versions up to, and including, 3.2.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2024-8323Wordfence advisoryCode change (fix)wordpress.orgPlugin source

medium 6.1 CVE-2024-8871 · published 2024-10-30

Reflected cross-site scripting (XSS) in Pricing Table WordPress Plugin (3.2.5 and older)

Affected
3.2.5 and older
Fixed in
unknown
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Pricing Tables WordPress Plugin – Easy Pricing Tables plugin for WordPress is vulnerable to Reflected Cross-Site Scripting due to the use of add_query_arg without appropriate escaping on the URL in all versions up to, and including, 3.2.5. This makes it possible for unauthenticated attackers to inject arbitrary web scripts in pages that execute if they can successfully trick a user into performing an action such as clicking on a link.

NVD CVE-2024-8871Wordfence advisoryPlugin source

medium 4.8 CVE-2021-36866 · published 2022-06-02

Stored cross-site scripting (XSS) in Pricing Table WordPress Plugin (3.1.2 and older)

Affected
3.1.2 and older
Fixed in
unknown
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Authenticated (author or higher role) Stored Cross-Site Scripting (XSS) vulnerability in Fatcat Apps Easy Pricing Tables plugin <= 3.1.2 at WordPress.

NVD CVE-2021-36866Patchstack advisorywordpress.org

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Pricing Table WordPress Plugin vulnerability status badge
<a href="https://laskyr.com/plugins/easy-pricing-tables"><img src="https://laskyr.com/plugins/easy-pricing-tables/badge.svg" alt="Pricing Table WordPress Plugin vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit