Plugins · easy-post-submission · data as of 2026-11-04
Is Easy Post Submission safe? Known vulnerabilities and latest version
- Latest version
- 2.6.0
- Last updated
- 2026-05-21
- Active installs
- 4,000+
- Known issues on record
- 3
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.4+
Enable users to submit posts and manage profiles from the front-end. Ideal for news, magazines, and creative platforms. — by ThemeRuby
What to do
- Update to the latest version (2.6.0). Anything older than 2.5.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get easy-post-submission --field=version shows what you run; wp plugin update easy-post-submission updates it.
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
critical 9.1 CVE-2026-4431 · published 2026-08-05
Missing authorization check in Easy Post Submission (2.3.0 and older)
- Affected
- 2.3.0 and older
- Fixed in
- 2.4.0 *
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Easy Post Submission plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the `create_post()` function in all versions up to, and including, 2.3.0. This is due to the `rbsm_submit_post` AJAX action being registered for unauthenticated users via `wp_ajax_nopriv_rbsm_submit_post` without any authorization checks when a `postId` parameter is supplied. This makes it possible for unauthenticated attackers to modify the title, content, excerpt, categories, and tags of arbitrary posts, as well as change the post status to draft (effectively unpublishing them) via the 'postId' parameter.
NVD CVE-2026-4431Wordfence advisoryCode change (fix)Plugin source
high 7.5 CVE-2026-22479 · published 2026-03-05
Missing authorization check in Easy Post Submission (2.4.0 and older)
- Affected
- 2.4.0 and older
- Fixed in
- 2.5.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in ThemeRuby Easy Post Submission easy-post-submission allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Easy Post Submission: from n/a through <= 2.4.0.
medium 5.5 CVE-2025-62062 · published 2025-10-22
Information disclosure in Easy Post Submission (1.7.0 and older)
- Affected
- 1.7.0 and older
- Fixed in
- 2.0.0
- Access needed (per CVSS)
- Needs an admin-level account
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Insertion of Sensitive Information Into Sent Data vulnerability in ThemeRuby Easy Post Submission easy-post-submission allows Retrieve Embedded Sensitive Data.This issue affects Easy Post Submission: from n/a through <= 1.7.0.
Recent activity
- 2026-05-21 — latest release on wordpress.org (2.6.0).
- 2026-08-05 — Missing authorization check disclosed (CVE-2026-4431), fixed in 2.4.0.
- 2026-03-05 — Missing authorization check disclosed (CVE-2026-22479), fixed in 2.5.0.
- 2025-10-22 — Information disclosure disclosed (CVE-2025-62062), fixed in 2.0.0.
Get an email when Easy Post Submission has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Easy Post Submission (easy-post-submission) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by ThemeRuby (2 tracked)
Types found in this plugin: Missing authorization (2) · Sensitive data exposure (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/easy-post-submission (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/easy-post-submission"><img src="https://laskyr.com/plugins/easy-post-submission/badge.svg" alt="Easy Post Submission vulnerability status"></a>