Plugins · easy-notify-lite · data as of 2026-11-04
Is Easy Notify Lite safe? Known vulnerabilities and latest version
- Latest version
- 1.1.39
- Last updated
- 2025-12-13
- Active installs
- 300+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 6.9.11
The best Popup Builder plugin to display image, video, notify or announcement with very ease and elegant. — by GhozyLab
What to do
- Update to the latest version (1.1.39). Anything older than 1.1.37 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get easy-notify-lite --field=version shows what you run; wp plugin update easy-notify-lite updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.4 CVE-2025-14446 · published 2025-12-13
Missing authorization check in Easy Notify Lite (1.1.37 and older)
- Affected
- 1.1.37 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Popup Builder (Easy Notify Lite) plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the easynotify_cp_reset() function in all versions up to, and including, 1.1.37. This makes it possible for authenticated attackers, with Subscriber-level access and above, to reset plugin settings to their default values.
NVD CVE-2025-14446Wordfence advisoryCode change (fix)Plugin source
high 7.5 CVE-2025-46230 · published 2025-04-24
File inclusion in Easy Notify Lite (1.1.35 and older)
- Affected
- 1.1.35 and older
- Fixed in
- 1.1.37
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in GhozyLab Popup Builder easy-notify-lite allows PHP Local File Inclusion.This issue affects Popup Builder: from n/a through <= 1.1.35.
medium 6.5 CVE-2025-26882 · published 2025-02-25
Stored cross-site scripting (XSS) in Easy Notify Lite (1.1.33 and older)
- Affected
- 1.1.33 and older
- Fixed in
- 1.1.35
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in GhozyLab Popup Builder easy-notify-lite allows Stored XSS.This issue affects Popup Builder: from n/a through <= 1.1.33.
medium 6.5 CVE-2024-34567 · published 2024-05-17
Stored cross-site scripting (XSS) in Easy Notify Lite (1.1.29 and older)
- Affected
- 1.1.29 and older
- Fixed in
- 1.1.30
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in GhozyLab, Inc. Popup Builder allows Stored XSS.This issue affects Popup Builder: from n/a through 1.1.29.
Recent activity
- 2025-12-13 — latest release on wordpress.org (1.1.39).
- 2025-12-13 — Missing authorization check disclosed (CVE-2025-14446), fix version not stated.
- 2025-04-24 — File inclusion disclosed (CVE-2025-46230), fixed in 1.1.37.
- 2025-02-25 — Stored cross-site scripting (XSS) disclosed (CVE-2025-26882), fixed in 1.1.35.
Get an email when Easy Notify Lite has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Easy Notify Lite (easy-notify-lite) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by GhozyLab (4 tracked)
Types found in this plugin: Cross-site scripting (XSS) (2) · Missing authorization (1) · File inclusion (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/easy-notify-lite (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/easy-notify-lite"><img src="https://laskyr.com/plugins/easy-notify-lite/badge.svg" alt="Easy Notify Lite vulnerability status"></a>