Skip to content
Laskyr

Plugins · easy-modal · data as of 2026-11-04

Is Easy Modal safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.2.1)

As of 2026-11-04. 3 issues are on record for older versions; version 2.2.0 or newer fixes all of them that state a fix.

Latest version
2.2.1
Last updated
2026-09-09
Active installs
7,000+
Known issues on record
3
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Create unlimited accessible modal windows and reusable visual themes using content from the WordPress editor. — by Daniel Iser

What to do

  1. Update to the latest version (2.2.1). Anything older than 2.2.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get easy-modal --field=version shows what you run; wp plugin update easy-modal updates it.

Check your version

Known vulnerabilities

3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.5 CVE-2026-24617 · published 2026-01-23

Stored cross-site scripting (XSS) in Easy Modal (2.1.0 and older)

Affected
2.1.0 and older
Fixed in
2.2.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Daniel Iser Easy Modal easy-modal allows Stored XSS.This issue affects Easy Modal: from n/a through <= 2.1.0.

NVD CVE-2026-24617Patchstack advisory

high 7.2 CVE-2017-12946 · published 2017-08-18

SQL injection in Easy Modal (2.0.17 and older)

Affected
2.0.17 and older
Fixed in
2.1.0 *
Access needed (per CVSS)
Needs an admin-level account
Range from
NVD analysis · score by NVD
Details from the advisory

classes\controller\admin\modals.php in the Easy Modal plugin before 2.1.0 for WordPress has SQL injection in a delete action with the id, ids, or modal parameter to wp-admin/admin.php, exploitable by administrators.

NVD CVE-2017-12946wordpress.orgdefensecode.com

high 7.2 CVE-2017-12947 · published 2017-08-18

SQL injection in Easy Modal (2.0.17 and older)

Affected
2.0.17 and older
Fixed in
2.1.0 *
Access needed (per CVSS)
Needs an admin-level account
Range from
NVD analysis · score by NVD
Details from the advisory

classes\controller\admin\modals.php in the Easy Modal plugin before 2.1.0 for WordPress has SQL injection in an untrash action with the id, ids, or modal parameter to wp-admin/admin.php, exploitable by administrators.

NVD CVE-2017-12947wordpress.orgdefensecode.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Easy Modal vulnerability status badge
<a href="https://laskyr.com/plugins/easy-modal"><img src="https://laskyr.com/plugins/easy-modal/badge.svg" alt="Easy Modal vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit