Skip to content
Laskyr

Plugins · easy-media-download · data as of 2026-11-04

Is Easy Media Download safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.1.12)

As of 2026-11-04. 2 issues are on record for older versions; version 1.1.12 or newer fixes all of them that state a fix.

Latest version
1.1.12
Last updated
2026-08-23
Active installs
9,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4

Easy Media Download allows you to embed download buttons on your WordPress site. Add file download functionality with this WordPress download plugin. — by Noor Alam

What to do

  1. Update to the latest version (1.1.12). Anything older than 1.1.12 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get easy-media-download --field=version shows what you run; wp plugin update easy-media-download updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 5.4 CVE-2025-69169 · published 2026-01-08

Cross-site scripting (XSS) in Easy Media Download (1.1.11 and older)

Affected
1.1.11 and older
Fixed in
1.1.12
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Script-Related HTML Tags in a Web Page (Basic XSS) vulnerability in Noor Alam Easy Media Download easy-media-download allows Reflection Injection.This issue affects Easy Media Download: from n/a through <= 1.1.11.

NVD CVE-2025-69169Patchstack advisory

medium 5.4 CVE-2021-24699 · published 2021-10-25

Stored cross-site scripting (XSS) in Easy Media Download (older than 1.1.7)

Affected
older than 1.1.7
Fixed in
1.1.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The Easy Media Download WordPress plugin before 1.1.7 does not escape the text argument of its shortcode, which could allow users with a role as low as Contributor to perform Stored Cross-Site Scripting attacks.

NVD CVE-2021-24699WPScan advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Easy Media Download vulnerability status badge
<a href="https://laskyr.com/plugins/easy-media-download"><img src="https://laskyr.com/plugins/easy-media-download/badge.svg" alt="Easy Media Download vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit