Skip to content
Laskyr

Plugins · easy-image-gallery · data as of 2026-11-04

Is Easy Image Gallery safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (1.5.7)

As of 2026-11-04. 2 issues are on record for older versions; version 1.5.4 or newer fixes all of them that state a fix.

Latest version
1.5.7
Last updated
2026-10-25
Active installs
4,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4.0+

Easily create an image gallery on your posts, pages or any custom post type — by DevriX

What to do

  1. Update to the latest version (1.5.7). Anything older than 1.5.4 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get easy-image-gallery --field=version shows what you run; wp plugin update easy-image-gallery updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-4766 · published 2026-03-25

Stored cross-site scripting (XSS) in Easy Image Gallery (1.5.3 and older)

Affected
1.5.3 and older
Fixed in
1.5.4 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Easy Image Gallery plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the Gallery shortcode post meta field in all versions up to, and including, 1.5.3. This is due to insufficient input sanitization and output escaping on user-supplied gallery shortcode values. This makes it possible for authenticated attackers, with Contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2026-4766Wordfence advisoryPlugin source

medium 6.4 CVE-2025-2540 · published 2025-07-03

Stored cross-site scripting (XSS) in Easy Image Gallery (1.5.2 and older)

Affected
1.5.2 and older
Fixed in
1.5.3 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

Multiple plugins for WordPress are vulnerable to Stored Cross-Site Scripting via the plugin's bundled prettyPhoto library (version 3.1.6) in various versions due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-2540Wordfence advisoryCode change (fix)Plugin source

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Easy Image Gallery vulnerability status badge
<a href="https://laskyr.com/plugins/easy-image-gallery"><img src="https://laskyr.com/plugins/easy-image-gallery/badge.svg" alt="Easy Image Gallery vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit