Skip to content
Laskyr

Plugins · easy-image-collage · data as of 2026-11-04

Is Easy Image Collage safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.1)

As of 2026-11-04. 2 issues are on record for older versions; version 2.0.0 or newer fixes all of them that state a fix.

Latest version
2.0.1
Last updated
2026-08-19
Active installs
3,000+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4

Create beautiful responsive image collages for all your posts and pages — by Brecht

What to do

  1. Update to the latest version (2.0.1). Anything older than 2.0.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get easy-image-collage --field=version shows what you run; wp plugin update easy-image-collage updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.4 CVE-2026-9019 · published 2026-06-10

Stored cross-site scripting (XSS) in Easy Image Collage (1.13.6 and older)

Affected
1.13.6 and older
Fixed in
2.0.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Easy Image Collage plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'grid[properties][borderColor]' and 'grid[images][N][attachment_url]' Parameters in all versions up to, and including, 1.13.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with author-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. Because the data is stored via update_post_meta() rather than wp_insert_post() post content, WordPress's unfiltered_html restriction does not apply, meaning Authors cannot be blocked from this attack path by capability controls alone.

NVD CVE-2026-9019Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2024-5863 · published 2024-06-28

Missing authorization check in Easy Image Collage (1.13.5 and older)

Affected
1.13.5 and older
Fixed in
1.13.6 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Easy Image Collage plugin for WordPress is vulnerable to unauthorized loss of data due to a missing capability check on the ajax_image_collage() function in all versions up to, and including, 1.13.5. This makes it possible for authenticated attackers, with Contributor-level access and above, to erase all of the content in arbitrary posts.

NVD CVE-2024-5863Wordfence advisoryCode change (fix)

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Easy Image Collage vulnerability status badge
<a href="https://laskyr.com/plugins/easy-image-collage"><img src="https://laskyr.com/plugins/easy-image-collage/badge.svg" alt="Easy Image Collage vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit