Plugins · easy-form · data as of 2026-11-04
Is Easy Form safe? Known vulnerabilities and latest version
- Latest version
- 2.8.1
- Last updated
- 2026-04-14
- Active installs
- 100+
- Known issues on record
- 4
- Unpatched in latest
- 0
- Tested up to WP
- 7.0.8 · PHP 7.0+
The best WordPress form builder plugin. Create contact forms, subscription forms, payment forms, or any custom forms in minutes. — by Ays Pro
What to do
- Update to the latest version (2.8.1). Anything older than 2.8.0 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get easy-form --field=version shows what you run; wp plugin update easy-form updates it.
Check your version
Known vulnerabilities
4 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 5.3 CVE-2026-32332 · published 2026-03-13
Missing authorization check in Easy Form (2.7.9 and older)
- Affected
- 2.7.9 and older
- Fixed in
- 2.8.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Ays Pro Easy Form easy-form allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Easy Form: from n/a through <= 2.7.9.
high 7.5 CVE-2025-66117 · published 2025-12-18
Missing authorization check in Easy Form (2.7.8 and older)
- Affected
- 2.7.8 and older
- Fixed in
- 2.7.9
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Missing Authorization vulnerability in Ays Pro Easy Form easy-form allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Easy Form: from n/a through <= 2.7.8.
high 7.1 CVE-2025-27285 · published 2025-04-17
Reflected cross-site scripting (XSS) in Easy Form (2.6.9 and older)
- Affected
- 2.6.9 and older
- Fixed in
- 2.7.0
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Ays Pro Easy Form easy-form allows Reflected XSS.This issue affects Easy Form: from n/a through <= 2.6.9.
medium 4.8 CVE-2023-32498 · published 2023-08-23
Stored cross-site scripting (XSS) in Easy Form (1.2.0 and older)
- Affected
- 1.2.0 and older
- Fixed in
- 1.2.1
- Access needed (per CVSS)
- Needs an admin-level account; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
Auth. (admin+) Stored Cross-Site Scripting (XSS) vulnerability in Easy Form team Easy Form by AYS plugin <= 1.2.0 versions.
Recent activity
- 2026-04-14 — latest release on wordpress.org (2.8.1).
- 2026-03-13 — Missing authorization check disclosed (CVE-2026-32332), fixed in 2.8.0.
- 2025-12-18 — Missing authorization check disclosed (CVE-2025-66117), fixed in 2.7.9.
- 2025-04-17 — Reflected cross-site scripting (XSS) disclosed (CVE-2025-27285), fixed in 2.7.0.
Get an email when Easy Form has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Easy Form (easy-form) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by Ays Pro (13 tracked)
Types found in this plugin: Missing authorization (2) · Cross-site scripting (XSS) (2)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/easy-form (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/easy-form"><img src="https://laskyr.com/plugins/easy-form/badge.svg" alt="Easy Form vulnerability status"></a>