Skip to content
Laskyr

Plugins · easy-fancybox · data as of 2026-11-04

Is Firelight Lightbox safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.3.25)

As of 2026-11-04. 8 issues are on record for older versions; version 2.3.24 or newer fixes all of them that state a fix.

Latest version
2.3.25
Last updated
2026-10-05
Active installs
200,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.0+

Formerly Easy Fancybox. The most popular WordPress lightbox plugin. Simple, fast, and responsive. Opens images, videos, PDFs, and custom popups. — by Firelight

What to do

  1. Update to the latest version (2.3.25). Anything older than 2.3.24 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get easy-fancybox --field=version shows what you run; wp plugin update easy-fancybox updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

medium 6.8 CVE-2026-118438 · published 2026-10-31

Cross-site scripting (XSS) in Firelight Lightbox (older than 2.3.24)

Affected
older than 2.3.24
Fixed in
2.3.24
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Firelight Lightbox WordPress plugin before 2.3.24 does not properly escape image attribute values before processing them in the browser, which could allow users with contributor-level access and above to inject arbitrary web scripts that execute when another user views or previews the affected content.

NVD CVE-2026-118438WPScan advisory

medium 6.8 CVE-2026-118165 · published 2026-10-30

Stored cross-site scripting (XSS) in Firelight Lightbox (older than 2.3.23)

Affected
older than 2.3.23
Fixed in
2.3.23
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Firelight Lightbox WordPress plugin before 2.3.23 does not escape the URL of links it opens in its Classic lightbox before inserting it into the page as HTML, which could allow users with a role as low as Contributor to perform Stored Cross-Site Scripting attacks against users who click a crafted link.

NVD CVE-2026-118165WPScan advisory

medium 6.4 CVE-2026-6454 · published 2026-07-24

Cross-site scripting (XSS) in Firelight Lightbox (2.3.20 and older)

Affected
2.3.20 and older
Fixed in
2.3.21 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Firelight Lightbox plugin for WordPress is vulnerable to Stored DOM Cross-Site Scripting in versions up to and including 2.3.20. This is due to insufficient sanitization of the href attribute value within the FancyBox V2 PDF beforeLoad JavaScript callback generated in inc/fancybox-2.php, where this.href is string-concatenated directly into an HTML string without escaping, allowing a stored href containing entity-encoded double-quotes to break out of the data attribute and inject arbitrary event handlers into the DOM. This makes it possible for authenticated attackers with contributor-level access and above to inject arbitrary web scripts into pages that execute whenever a user clicks the malicious PDF link.

NVD CVE-2026-6454Wordfence advisoryCode change (fix)Plugin source

medium 5.4 CVE-2025-5035 · published 2025-06-27

Stored cross-site scripting (XSS) in Firelight Lightbox (older than 2.3.16)

Affected
older than 2.3.16
Fixed in
2.3.16
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Firelight Lightbox WordPress plugin before 2.3.16 does not sanitise and escape title attributes before outputting them in the page, which could allow users with a role as low as contributors to perform stored Cross-Site Scripting attacks.

NVD CVE-2025-5035WPScan advisory

medium 6.5 CVE-2025-52707 · published 2025-06-20

Stored cross-site scripting (XSS) in Firelight Lightbox (2.3.16 and older)

Affected
2.3.16 and older
Fixed in
2.3.17
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Firelight Firelight Lightbox easy-fancybox allows Stored XSS.This issue affects Firelight Lightbox: from n/a through <= 2.3.16.

NVD CVE-2025-52707Patchstack advisory

medium 5.9 CVE-2025-3597 · published 2025-05-12

Security issue in Firelight Lightbox (older than 2.3.15)

Affected
older than 2.3.15
Fixed in
2.3.15
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by CISA ADP
Details from the advisory

The Firelight Lightbox WordPress plugin before 2.3.15 does not prevent users with post writing capabilities from executing arbitrary Javascript when the jQuery Metadata library is enabled. While this feature is meant to only be available to Pro version users, it can be activated in the free version too, making it theoretically exploitable there as well.

NVD CVE-2025-3597WPScan advisory

medium 4.8 CVE-2024-50460 · published 2024-10-28

Stored cross-site scripting (XSS) in Firelight Lightbox (2.3.3 and older)

Affected
2.3.3 and older
Fixed in
2.3.4
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by NVD
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Firelight Firelight Lightbox easy-fancybox allows Stored XSS.This issue affects Firelight Lightbox: from n/a through <= 2.3.3.

NVD CVE-2024-50460Patchstack advisory

medium 4.8 CVE-2019-16524 · published 2019-09-26

Stored cross-site scripting (XSS) in Firelight Lightbox (older than 1.8.18)

Affected
older than 1.8.18
Fixed in
1.8.18
Access needed (per CVSS)
Needs an admin-level account; someone on the site has to click a link or open a page
Range from
NVD analysis · score by NVD
Details from the advisory

The easy-fancybox plugin before 1.8.18 for WordPress (aka Easy FancyBox) is susceptible to Stored XSS in the Settings Menu inc/class-easyfancybox.php due to improper encoding of arbitrarily submitted settings parameters. This occurs because there is no inline styles output filter.

NVD CVE-2019-16524wordpress.orggithub.comwpvulndb.com

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Firelight Lightbox vulnerability status badge
<a href="https://laskyr.com/plugins/easy-fancybox"><img src="https://laskyr.com/plugins/easy-fancybox/badge.svg" alt="Firelight Lightbox vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit