Plugins · easy-elements · data as of 2026-11-04
Is Easy Elements for Elementor safe? Known vulnerabilities and latest version
- Status
- Closed 2026-08-17
- Known issues on record
- 3
- Unpatched in latest
- 0
What to do
- Replace it. A closed plugin gets no updates through WordPress, so any hole found from now on stays open.
- Deactivate and delete it once you have a replacement (Plugins → Deactivate → Delete). Deleting removes its files; deactivating alone leaves them on the server.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI, once you have a replacement: wp plugin deactivate easy-elements && wp plugin delete easy-elements
Check your version
Known vulnerabilities
3 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version. 3 record(s) do not state which versions are affected.
critical 9.8 CVE-2026-56028 · published 2026-06-26
Privilege escalation in Easy Elements for Elementor (1.4.9 and older)
- Affected
- 1.4.9 and older
- Fixed in
- 1.5.0
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Unauthenticated Privilege Escalation in Easy Elements for Elementor – Addons & Website Templates <= 1.4.9 versions.
high 8.8 CVE-2026-9018 · published 2026-05-22
Privilege escalation in Easy Elements for Elementor (1.4.5 and older)
- Affected
- 1.4.5 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Easy Elements for Elementor – Addons & Website Templates plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 1.4.5 via the `easyel_handle_register()` function. This is due to the `wp_ajax_nopriv_eel_register` AJAX handler iterating the attacker-controlled `custom_meta` POST array and writing every supplied key-value pair to the newly created user's meta via `update_user_meta()` without any key whitelist or blocklist, allowing the `wp_capabilities` user meta key to be overwritten after `wp_insert_user()` has already assigned a safe role. This makes it possible for unauthenticated attackers to register a new account with full administrator-level privileges by supplying `custom_meta[wp_capabilities][administrator]=1`. Exploitation requires that user registration is enabled on the site and that at least one page exposes the Login/Register widget, which publishes the required `easy_elements_nonce` into the page DOM where it can be retrieved by any unauthenticated visitor via a simple GET request.
critical 9.8 CVE-2026-7284 · published 2026-05-20
Privilege escalation in Easy Elements for Elementor (1.4.4 and older)
- Affected
- 1.4.4 and older
- Fixed in
- unknown
- Access needed (per CVSS)
- No login needed
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Easy Elements for Elementor – Addons & Website Templates plugin for WordPress is vulnerable to privilege escalation via user registration in all versions up to, and including, 1.4.4. This is due to the 'easyel_handle_register' function not restricting what user roles a user can register with. This makes it possible for unauthenticated attackers to supply the 'administrator' role during registration and gain administrator access to the site.
NVD CVE-2026-7284Wordfence advisoryCode change (fix)Plugin source
Recent activity
- 2026-08-17 — closed on wordpress.org (Guideline Violation).
- 2026-06-26 — Privilege escalation disclosed (CVE-2026-56028), fixed in 1.5.0.
- 2026-05-22 — Privilege escalation disclosed (CVE-2026-9018), fix version not stated.
- 2026-05-20 — Privilege escalation disclosed (CVE-2026-7284), fix version not stated.
Get an email when Easy Elements for Elementor has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Easy Elements for Elementor (easy-elements) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Privilege escalation (3)
Where this data comes from
- Version, last update, installs, closure: wordpress.org/plugins/easy-elements (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/easy-elements"><img src="https://laskyr.com/plugins/easy-elements/badge.svg" alt="Easy Elements for Elementor vulnerability status"></a>