Skip to content
Laskyr

Plugins · easy-elementor-addons · data as of 2026-11-04

Is Easy Elementor Addons safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.5.0)

As of 2026-11-04. 8 issues are on record for older versions; version 2.3.8 or newer fixes all of them that state a fix.

Latest version
2.5.0
Last updated
2026-10-30
Active installs
1,000+
Known issues on record
8
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4+

Level up with Easy Elementor Addons – adds powerful widgets and sleek design tools to your favorite Elementor page builder. — by hashthemes

What to do

  1. Update to the latest version (2.5.0). Anything older than 2.3.8 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get easy-elementor-addons --field=version shows what you run; wp plugin update easy-elementor-addons updates it.

Check your version

Known vulnerabilities

8 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

critical 9.6 CVE-2026-28164 · published 2026-08-20

Cross-site request forgery (CSRF) in Easy Elementor Addons (2.3.7 and older)

Affected
2.3.7 and older
Fixed in
2.3.8
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Cross-Site Request Forgery (CSRF) vulnerability in HashThemes Easy Elementor Addons allows Cross Site Request Forgery. This issue affects Easy Elementor Addons: from n/a through 2.3.7.

NVD CVE-2026-28164Patchstack advisory

medium 6.4 CVE-2025-9045 · published 2025-10-03

Stored cross-site scripting (XSS) in Easy Elementor Addons (2.2.9 and older)

Affected
2.2.9 and older
Fixed in
2.3.0 *
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Wordfence
Details from the advisory

The Easy Elementor Addons plugin for WordPress is vulnerable to Stored Cross-Site Scripting via several widget parameters in versions less than, or equal to, 2.2.9 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.

NVD CVE-2025-9045Wordfence advisoryPlugin source

high 7.5 CVE-2025-58973 · published 2025-09-22

File inclusion in Easy Elementor Addons (2.2.8 and older)

Affected
2.2.8 and older
Fixed in
2.2.9
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in hashthemes Easy Elementor Addons easy-elementor-addons allows PHP Local File Inclusion.This issue affects Easy Elementor Addons: from n/a through <= 2.2.8.

NVD CVE-2025-58973Patchstack advisory

medium 4.3 CVE-2025-54712 · published 2025-08-14

Missing authorization check in Easy Elementor Addons (2.2.7 and older)

Affected
2.2.7 and older
Fixed in
2.2.8
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber)
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Missing Authorization vulnerability in hashthemes Easy Elementor Addons easy-elementor-addons allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Easy Elementor Addons: from n/a through <= 2.2.7.

NVD CVE-2025-54712Patchstack advisory

medium 6.5 CVE-2025-54704 · published 2025-08-14

Cross-site scripting (XSS) in Easy Elementor Addons (2.2.6 and older)

Affected
2.2.6 and older
Fixed in
2.2.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in hashthemes Easy Elementor Addons easy-elementor-addons allows DOM-Based XSS.This issue affects Easy Elementor Addons: from n/a through <= 2.2.6.

NVD CVE-2025-54704Patchstack advisory

medium 6.5 CVE-2025-48295 · published 2025-07-16

Stored cross-site scripting (XSS) in Easy Elementor Addons (2.2.5 and older)

Affected
2.2.5 and older
Fixed in
2.2.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in hashthemes Easy Elementor Addons easy-elementor-addons allows Stored XSS.This issue affects Easy Elementor Addons: from n/a through <= 2.2.5.

NVD CVE-2025-48295Patchstack advisory

medium 6.5 CVE-2025-26912 · published 2025-02-25

Stored cross-site scripting (XSS) in Easy Elementor Addons (2.1.6 and older)

Affected
2.1.6 and older
Fixed in
2.1.7
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in hashthemes Easy Elementor Addons easy-elementor-addons allows Stored XSS.This issue affects Easy Elementor Addons: from n/a through <= 2.1.6.

NVD CVE-2025-26912Patchstack advisory

medium 6.5 CVE-2025-26761 · published 2025-02-16

Cross-site scripting (XSS) in Easy Elementor Addons (2.1.5 and older)

Affected
2.1.5 and older
Fixed in
2.1.6
Access needed (per CVSS)
Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in hashthemes Easy Elementor Addons easy-elementor-addons allows DOM-Based XSS.This issue affects Easy Elementor Addons: from n/a through <= 2.1.5.

NVD CVE-2025-26761Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
Easy Elementor Addons vulnerability status badge
<a href="https://laskyr.com/plugins/easy-elementor-addons"><img src="https://laskyr.com/plugins/easy-elementor-addons/badge.svg" alt="Easy Elementor Addons vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit