Plugins · easy-accordion-free · data as of 2026-11-04
Is Easy Accordion safe? Known vulnerabilities and latest version
- Latest version
- 3.1.11
- Last updated
- 2026-10-13
- Active installs
- 70,000+
- Known issues on record
- 5
- Unpatched in latest
- 0
- Tested up to WP
- 7.1.4 · PHP 7.4+
AI-Powered FAQ Generator. Gutenberg FAQ & Accordion Blocks, Image Accordion, Accordion Slider, WooCommerce Product FAQ – Elementor & Shortcode Ready. — by ShapedPlugin LLC
What to do
- Update to the latest version (3.1.11). Anything older than 3.1.9 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
- If you cannot update right away, deactivate it until you can.
- Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.
With WP-CLI: wp plugin get easy-accordion-free --field=version shows what you run; wp plugin update easy-accordion-free updates it.
Check your version
Known vulnerabilities
5 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
medium 6.4 CVE-2026-18988 · published 2026-08-08
Stored cross-site scripting (XSS) in Easy Accordion (3.1.8 and older)
- Affected
- 3.1.8 and older
- Fixed in
- 3.1.9 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Easy Accordion plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'accordionTitleTag' block attribute in versions up to, and including, 3.1.8. This is due to insufficient input sanitization and output escaping in the accordion_header_renderer() function, which emits the attacker-supplied tag name using esc_attr() in an HTML tag-name context instead of tag_escape(). This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-18988Wordfence advisoryCode change (fix)Plugin source
medium 6.4 CVE-2026-15652 · published 2026-07-16
Stored cross-site scripting (XSS) in Easy Accordion (3.1.6 and older)
- Affected
- 3.1.6 and older
- Fixed in
- 3.1.7 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber)
- Range from
- CVE record (the advisory publisher) · score by Wordfence
Details from the advisory
The Easy Accordion – AI-Powered FAQ & Accordion Blocks, Product FAQ plugin for WordPress is vulnerable to Stored Cross-Site Scripting via 'align' Block Attribute in all versions up to, and including, 3.1.6 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
NVD CVE-2026-15652Wordfence advisoryCode change (fix)Plugin source
medium 5.4 CVE-2024-1363 · published 2024-03-13
Stored cross-site scripting (XSS) in Easy Accordion (2.3.4 and older)
- Affected
- 2.3.4 and older
- Fixed in
- 2.3.5 *
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Easy Accordion – Best Accordion FAQ Plugin for WordPress plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'accordion_content_source' attribute in all versions up to, and including, 2.3.4 due to insufficient input sanitization and output escaping. This makes it possible for authenticated attackers, with contributor-level access and above, to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page.
medium 5.4 CVE-2022-4487 · published 2023-01-16
Stored cross-site scripting (XSS) in Easy Accordion (older than 2.2.0)
- Affected
- older than 2.2.0
- Fixed in
- 2.2.0
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by NVD
Details from the advisory
The Easy Accordion WordPress plugin before 2.2.0 does not validate and escape some of its shortcode attributes before outputting them back in the page, which could allow users with a role as low as contributor to perform Stored Cross-Site Scripting attacks which could be used against high privilege users such as admins.
medium 5.4 CVE-2021-24576 · published 2021-10-11
Cross-site scripting (XSS) in Easy Accordion (older than 2.0.22)
- Affected
- older than 2.0.22
- Fixed in
- 2.0.22
- Access needed (per CVSS)
- Needs a low-level account (e.g. subscriber); someone on the site has to click a link or open a page
- Range from
- advisory text · score by NVD
Details from the advisory
The Easy Accordion WordPress plugin before 2.0.22 does not properly sanitize inputs when adding new items to an accordion.
Recent activity
- 2026-10-13 — latest release on wordpress.org (3.1.11).
- 2026-08-08 — Stored cross-site scripting (XSS) disclosed (CVE-2026-18988), fixed in 3.1.9.
- 2026-07-16 — Stored cross-site scripting (XSS) disclosed (CVE-2026-15652), fixed in 3.1.7.
- 2024-03-13 — Stored cross-site scripting (XSS) disclosed (CVE-2024-1363), fixed in 2.3.5.
Get an email when Easy Accordion has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for Easy Accordion (easy-accordion-free) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
- Published this week
- Unpatched in the latest version
- By type of vulnerability
- Plugins by ShapedPlugin LLC (6 tracked)
Types found in this plugin: Cross-site scripting (XSS) (5)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/easy-accordion-free (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/easy-accordion-free"><img src="https://laskyr.com/plugins/easy-accordion-free/badge.svg" alt="Easy Accordion vulnerability status"></a>