Plugins · e-shops-cart2 · data as of 2026-11-04
Is e-shopsカート2 safe? Known vulnerabilities and latest version
- Latest version
- 1.0.4
- Last updated
- 2025-07-02
- Active installs
- 50+
- Known issues on record
- 2
- Unpatched in latest
- 1
- Tested up to WP
- 6.8.12
商品ページに「買物カゴ」ボタンを貼ることができるプラグインです。ネットショップとして商品を販売することが可能になります。簡単にECサイトに。 — by hands01
What to do
- There is no fixed version yet. If you can live without e-shopsカート2 for now, deactivate it and delete it until the developer ships a fix.
- If you must keep it, limit who can log in (remove unused accounts, especially low-level ones) and put a web application firewall in front of the site.
- Watch for an update: get an email when this page changes.
- If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan, or have us clean it: Emergency Cleanup, $499.
With WP-CLI: wp plugin get e-shops-cart2 --field=version shows what you run; wp plugin update e-shops-cart2 updates it.
Check your version
Known vulnerabilities
2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.
high 7.1 affects latest 1.0.4 CVE-2025-68890 · published 2026-01-08
Cross-site scripting (XSS) in e-shopsカート2 (1.0.4 and older)
- Affected
- 1.0.4 and older
- Fixed in
- no fix listed yet
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in hands01 e-shops e-shops-cart2 allows DOM-Based XSS.This issue affects e-shops: from n/a through <= 1.0.4.
high 7.1 CVE-2024-51648 · published 2024-11-19
Cross-site request forgery (CSRF) in e-shopsカート2 (1.0.3 and older)
- Affected
- 1.0.3 and older
- Fixed in
- 1.0.4
- Access needed (per CVSS)
- No login needed; someone on the site has to click a link or open a page
- Range from
- CVE record (the advisory publisher) · score by Patchstack
Details from the advisory
Cross-Site Request Forgery (CSRF) vulnerability in hands01 e-shops e-shops-cart2 allows Reflected XSS.This issue affects e-shops: from n/a through <= 1.0.3.
Recent activity
- 2025-07-02 — latest release on wordpress.org (1.0.4).
- 2026-01-08 — Cross-site scripting (XSS) disclosed (CVE-2025-68890), no fix listed yet.
- 2024-11-19 — Cross-site request forgery (CSRF) disclosed (CVE-2024-51648), fixed in 1.0.4.
Get an email when e-shopsカート2 has a new vulnerability
Free. We check the CVE feeds every day and email you only when a new issue for e-shopsカート2 (e-shops-cart2) is published or a fix ships. Unsubscribe in one click.
Browse vulnerabilities
Types found in this plugin: Cross-site scripting (XSS) (1) · Cross-site request forgery (CSRF) (1)
Where this data comes from
- Version, last update, installs: wordpress.org/plugins/e-shops-cart2 (Plugins API), fetched 2026-11-04.
- Vulnerabilities: NIST National Vulnerability Database (NVD), checked 2026-11-04. This product uses data from the NVD API but is not endorsed or certified by the NVD.
- Each record links to its CVE page and to the original advisory (Wordfence, Patchstack or WPScan) where there is one. We only list a CVE here when its references or its advisory name this exact plugin, so a few real issues may be missing; none should be about a different plugin. Spot an error? Email Daniel.
Badge for your site or docs (states facts with a date, not a verdict):
<a href="https://laskyr.com/plugins/e-shops-cart2"><img src="https://laskyr.com/plugins/e-shops-cart2/badge.svg" alt="e-shopsカート2 vulnerability status"></a>