Skip to content
Laskyr

Plugins · dxp-toolkit · data as of 2026-11-04

Is DXP ToolKit safe? Known vulnerabilities and latest version

No known unpatched vulnerabilities in the latest version (2.0.2)

As of 2026-11-04. 2 issues are on record for older versions; version 2.0.2 or newer fixes all of them that state a fix.

Latest version
2.0.2
Last updated
2026-10-23
Active installs
10+
Known issues on record
2
Unpatched in latest
0
Tested up to WP
7.1.4 · PHP 7.4.0+

Customized content matters! Dynamically personalize your website content based on your user segments, connect your content directly with your Analytic … — by Crowd Favorite

What to do

  1. Update to the latest version (2.0.2). Anything older than 2.0.2 has at least one known issue listed below. Dashboard → Updates, or Plugins → “update now”.
  2. If you cannot update right away, deactivate it until you can.
  3. Turn on auto-updates for it: Plugins → “Enable auto-updates” on its row.
  4. If you ran a vulnerable version and something looks off (spam pages, strange admins, redirects), run the free scan.

With WP-CLI: wp plugin get dxp-toolkit --field=version shows what you run; wp plugin update dxp-toolkit updates it.

Check your version

Known vulnerabilities

2 on record, newest first. “Affected” is the version range the source gives; “fixed in” is the version the source names, or (marked *) the first wordpress.org release after the last affected version.

high 7.1 CVE-2026-115606 · published 2026-10-28

Stored cross-site scripting (XSS) in DXP ToolKit (2.0.1 and older)

Affected
2.0.1 and older
Fixed in
2.0.2
Access needed (per CVSS)
No login needed; someone on the site has to click a link or open a page
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Crowd Favorite DXP ToolKit dxp-toolkit allows Stored XSS.This issue affects DXP ToolKit: from n/a through 2.0.1.

NVD CVE-2026-115606Patchstack advisory

critical 9.3 CVE-2026-115607 · published 2026-10-28

SQL injection in DXP ToolKit (2.0.1 and older)

Affected
2.0.1 and older
Fixed in
2.0.2
Access needed (per CVSS)
No login needed
Range from
CVE record (the advisory publisher) · score by Patchstack
Details from the advisory

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in Crowd Favorite DXP ToolKit dxp-toolkit allows SQL Injection.This issue affects DXP ToolKit: from n/a through 2.0.1.

NVD CVE-2026-115607Patchstack advisory

Recent activity

Browse vulnerabilities

Where this data comes from

Badge for your site or docs (states facts with a date, not a verdict):
DXP ToolKit vulnerability status badge
<a href="https://laskyr.com/plugins/dxp-toolkit"><img src="https://laskyr.com/plugins/dxp-toolkit/badge.svg" alt="DXP ToolKit vulnerability status"></a>

← Check another plugin · Free hacked-site scan

First hour checklist

If the site was just hacked, read the emergency kit before you delete files. The page is free. Email is optional.

Read the emergency kit